Topic Closed
jogai
264 Posts

Seems that the config from /include/js/ckeditor_config.js is not used. Or at least the source button is missing, and I cant get it back.

7 years ago#5203

Josh S.
2K Posts
267K Downloads
16 Themes
18 Plugins

Did you use the CKEditorConfig filter to set a value for customConfig?

Currently customConfig is set to /include/js/ckeditor_config.js. So, if the CKEditorConfig filter is used to set a customConfig value, the /include/js/ckeditor_config.js won't be loaded. I can definitely see how that wouldn't be ideal. We may have to just do away with the /include/js/ckeditor_config.js and put all it's values in with the configuration generated in php.

7 years ago#5208

jogai
264 Posts

No, I changed /include/js/ckeditor_config.js but it didnt have any effect.

7 years ago#5209

Josh S.
2K Posts
267K Downloads
16 Themes
18 Plugins

Or at least the source button is missing, and I cant get it back.

Sorry, I should have paid more attention to this part of the message. The source button is not available in CKEditor 4.0 for inline editing. It should be available in 4.1 which is due out in just over a week: http://dev.ckeditor.com/roadmap

7 years ago#5213

jogai
264 Posts

Thanks for the update. I'll watch your commits :)

7 years ago#5214

jogai
264 Posts

Related question, are we able to use the ckeditor builder?

sidenote: isnt it better to have versionless paths in include/thirdparty? Now its confusing. Maybe with a texfile in it with the versionnumber as filename. Just an idea.

7 years ago#5239

Josh S.
2K Posts
267K Downloads
16 Themes
18 Plugins

Are we able to use the ckeditor builder?

It should work. Just be sure not to delete the sharedspace plugin (it's not in the builder yet)

isnt it better to have versionless paths in include/thirdparty

I agree 100%. We've left the old version numbers in a few files/folders (like ckeditor_34) for backwards compatibility.

7 years ago#5241

Eric
193 Posts
1.4K Downloads
1 Themes

Ideally, third party folders should not be named with a version number but contain a text file identifying the version. I'm not sure how much that would affect backwards compatibility.

Also, custom configs should be outside of the gpEasy core files (possibly in data/_site folder), so they are not affected by gpEasy updates. gpEasy could look for the custom config file first and use it if it finds it, and use the default config if the custom config file does not exist.

This should be available for ckEditor and colorbox (to create custom styles), and possibly open to addons. 

7 years ago#5242

jogai
264 Posts

Ideally, third party folders should not be named with a version number but contain a text file identifying the version.

Thats what she I said.

custom configs should be outside of the gpEasy core files (possibly in data/_site folder)

indeed

This should be available for ckEditor and colorbox (to create custom styles), and possibly open to addons. 

And for the gallery styles. I still dont know how to do that properly.

 

7 years ago#5243

feniweb
297 Posts

I have the following error message,

User Notice (1024)
deprecated functions
     in / volume1/web/cms-ohne-db/gpEasy_3.6rc1/include/common.php
     on line: 903
     Request: / cms-ohne-db/gpEasy_3.6rc1/Admin_Uploaded
     Method: GET
Show backtrace

Also in the version history
Of a WYSIWYG with CKEditor 4 the talk
But in include / thirdparty folder is only a ckeditor_34 version?

greeting

7 years ago#5245

Josh S.
2K Posts
267K Downloads
16 Themes
18 Plugins

deprecated functions
in / volume1/web/cms-ohne-db/gpEasy_3.6rc1/include/common.php
on line: 903

Check the template.php file of your theme. There's probably a call to $page->GetExtra() instead of gpOutput::GetExtra()

But in include / thirdparty folder is only a ckeditor_34 version?

The name of the folder doesn't reflect the version.

The complications involved with removing those numbers may actually be less significant than the confusion they're causing.

7 years ago#5254

feniweb
297 Posts

Thanks for help I have removed $ page-> getextra () and now it works.

 

Thank you many times

Edited: 7 years ago#5292

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register