Topic Closed
mrplayboy
59 Posts

Hello Admin,

 

I just recently checked, that the guys of Bootstrap released a RC1 for Bootstrap 3 (http://getbootstrap.com), which has many, many changes. But especially one, I believe is the cherry-picker: Bootstrap 3 is mobile first.

As Bootstrap templates were integrated by you in the last major release, I wanted to ask several things:

1) Will the templates currently being integrated within gpEasy be updated to v3 (or replaced by the examples provided on the website)? If so, is there a chance to get a round-about date when to expect this?

2) I saw, that you were working on Github regarding the support of .less-files (https://github.com/oyejorge/gpEasy-CMS/commit/ec0a6de4d78f823270e1404f717a62e6a579bed8). As I am not really into coding: It looks, that gpEasy will be fully supporting Bootstrap? (Another sign: In the gallery carousel, the responsive design specifically gets mentioned :-) )

3) Follwing question 2: Does that mean, that there will be an easier way to integrate Bootstrap templates into gpEasy, without having them to modify specifically for gpEasy? If not, would that be possible to add on the roadmap?

There are soooooo many great free templates available (e.g. http://bootstrapthemes.quora.com/25-Awseome-Twitter-Bootstrap-Themes-For-Better-Bootstrap-Designs or http://inspiretrends.com/twitter-bootstrap-templates/ , etc.) which would be great to have with the gpEasy-System as this would give the real website power!

 

Thanks again for all your continuing support so far! I am sure, I am not the only one who is already really happy to have gpEasy!

Cheers

6 years ago#6483

Josh S.
2K Posts
266K Downloads
16 Themes
18 Plugins

1) Will the templates currently being integrated within gpEasy be updated to v3 (or replaced by the examples provided on the website)? If so, is there a chance to get a round-about date when to expect this?

We'll likely keep bootstrap 2 within gpEasy for some time to support anyone who has built on that infrastructure. We won't add bootstrap 3 to gpEasy until it's beyond the release candidate stage. Since there are likely conflicts, we probably won't replace the existing templates. Rather, we'll add v3 templates and phase out the v2 templates.

2) I saw, that you were working on Github regarding the support of .less-files...

I'm actually really excited about using LESS within gpEasy. I just added the bootstrap 2 LESS files and will be converting gpEasy's css files to less documents. I would say that we're very close to fully supporting bootstrap

3) Follwing question 2: Does that mean, that there will be an easier way to integrate Bootstrap templates into gpEasy, without having them to modify specifically for gpEasy?

I've actually been working on integrating the themes from http://bootswatch.com/. At the moment, there are a few more steps than just copying over the LESS files but not much.

There are soooooo many great free templates available.. which would be great to have with the gpEasy-System

Absolutely. gpEasy users need more theme options. It's one of the reasons I'm putting the time into LESS.

6 years ago#6484

Eric
193 Posts
1.4K Downloads
1 Themes

Take a look at the Cobbler theme. It is my attempt to make it easy to customize bootstrap.

I'm fairly new with bootstrap, but you should be able to place your templates in Cobbler fairly easily. Preferably use templates that include LESS styles. You'll have to modify them to include gpEasy-specific code and possibly modify the style sheet name.

I didn't realize Josh was working on getting LESS processed on the server side. It may be a good combination.

6 years ago#6485

mrplayboy
59 Posts

Thanks Josh and Eric for your kind and fast replies.

 

Really appreciate your support for Bootstrap/ LESS! As you mentioned, this is the future and the earlier, the better (as long as it is stable *haha*).

Being really happy, that we as users can expect some further Bootstrap Themes in the near future - will be amazing!

6 years ago#6488

Eric
193 Posts
1.4K Downloads
1 Themes

Bootstrap 3 is officially out now. It is definitely not backwards-compatible. The entire grid system has changed, among other things. I predict a lot of issues with people using mismatched versions of bootstrap and themes.

Since Bootstrap implementation in gpEasy is fairly recent, and I would like to see it stay current with the latest technology. I suggest gpEasy incorporate both versions of the libraries (the latest 2.x and the latest 3.x, and next year add 4.x). Then add a setting on which library to use. The user will be able to select which one to use in settings.

You can probably maintain your calls to bootstrap to go to bootstrap 2, and add new calls to bootstrap3.

As for implementing customization and LESS support, I'd focus on the newer version.

6 years ago#6532

Josh S.
2K Posts
266K Downloads
16 Themes
18 Plugins

It's good to see the Bootswatch themes have also been updated for 3.0

for implementing customization and LESS support, I'd focus on the newer version.

I was thinking the same thing.

I predict a lot of issues with people using mismatched versions of bootstrap and themes.

Definitely. I think themes will have to specify which version of bootstrap to include.

 

6 years ago#6553

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register