Topic Closed
feniweb
297 Posts

Are displayed in the editor, no pictures. Under new version TS5.0
I can not select images but when saving it writes only <img alt src>

3 years ago#9149

mahotilo
91 Posts

Yes, I also have a problem with images in last TS 5.0 from github.

1. Edit page

2. Insert image in page.

3. All looks like always

4. Save page and close

5. No image in page.

5. Edit page - still no image.

It is a showstopper for me. Please pay attention to this bug!

3 years ago#9151

Josh S.
2K Posts
264K Downloads
16 Themes
18 Plugins
Yikes, that's not good.

I haven't been able to reproduce the problem though on any of my test systems.

Would you mind trying it in a demo installation? (get a demo here) Here's mine with a test image I attached

Other info that might be helpful:
  • type of image (png, jpg, gif...)
  • size of image
  • or if you could link to the image that won't attach




3 years ago#9152

juergen
1.4K Posts
50.6K Downloads
16 Plugins
design, web development & visual effects

I can reproduce it with the current master.

My guess: Must have sth. to do with /include/tool/Editing/HTML.php, $required_attr array and  BuildAttributes() method

Must be a recent change. Works with 5.0 initial release.

edit:/ Likely in this commit

edit2:/ If one provides an alt attribute in CKEditor, the image survives hence the missing required alt attribute messes up the img tag.

Edited: 3 years ago#9153

Josh S.
2K Posts
264K Downloads
16 Themes
18 Plugins
Ah, I thought they were talking about the 5.0 release and not the master branch.
3 years ago#9154

Josh S.
2K Posts
264K Downloads
16 Themes
18 Plugins

Ok, all fixed. Thanks for putting me on the right track Juergen

3 years ago#9155

feniweb
297 Posts


It seems to work with the fix.

Thank you very much

Another problem here http://www.gpeasy.com/Forum?show=t2125#post_9027

3 years ago#9160

feniweb
297 Posts

It seems to work with the fix.

Thank you very much.

 

Another problem here http://www.gpeasy.com/Forum?show=t2125#post_9027

 

3 years ago#9161

globulle
4 Posts
Thank you @Josh S. for fixing it. Using the last stable release (5.0), how can I benefit from these changes? I am currently unable to include images in my website. Thank you for your help!
3 years ago#9206

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register