Topic Closed

As said on GitHub, I paste the problem here:

 

After filling the installation form a blank page appears and installation fails. No php errors.
When migrating an installed sited from ubuntu to debian login fails. No php errors either.

Debian 8, Apache 2.4 with php-fpm, php 5.6 using imscp.

:(

 

Link:  GitHub Issue

3 years ago#9471

juergen
1.4K Posts
51.4K Downloads
16 Plugins
design, web development & visual effects

Although I'm not much of an expert in the server configuration field, a few things come to my mind, I would try or check.

1st, has you debian machine selinux activated? If so, user/group/file/folder permissions get a lot more complicated (these caused me lots of headache on a CentOS server some 2 years ago).

2nd, what happens when you call a script - e.g. named pi.php - which only contains <?php phpinfo(); ?> from your Typesetter installation root. Do you get any output? If so, does it also work when you move it to the /include directory and call it from there?

3rd, is the server root path of the vHost wihch resolves your Typersetter installation in /var/www/ and if not, are there any symbolic links (symlinks) involved?

4th, do you get any response headers when you see the blank page?

 

Only my 5cents. Maybe completely irrelevant.

3 years ago#9472

juergen
1.4K Posts
51.4K Downloads
16 Plugins
design, web development & visual effects

Oh, and...

When migrating an installed sited from ubuntu to debian login fails

Does the apache user have write access to the /data directory (and all subdirectories/files)?

 

3 years ago#9473

1. No SELinux

2. Works in Root, in data and in include.

3. Yes, that has worked before on Ubuntu and is managed by imscp.

4. Interesting point. I get a 503 indeed. :/

And the virtual user has write permission.

 

3 years ago#9474

juergen
1.4K Posts
51.4K Downloads
16 Plugins
design, web development & visual effects
503? Hmmm. Smells like some infinite loop to me.
Edited: 3 years ago#9475

Not much to work with, without anything in the error.log.
3 years ago#9476

But I see that some other people have or had the same problem here.

This needs to be fixed, whatever it is.

So I tried for hours to figure out whats wrong, the next step would be to set up a test enviroment where more skilled people can try to see it.

 

Edited: 3 years ago#9477

fly06
263 Posts
18.1K Downloads
1 Themes
8 Plugins

In the gpconfig.php file, can you set 'gdebug' to true and 'display_errors' to 1.

Save and try to reinstall...

3 years ago#9478

juergen
1.4K Posts
51.4K Downloads
16 Plugins
design, web development & visual effects

Doesn't help much but FYI:
I just changed a local development server from mod_php to php5-fpm and did a fresh TS 5.0.3 install and everything works fine here.
But it's not Debian...

Ubuntu 14.04
Apache 2.4.7
PHP 5.5.9

edit: Anything in php5-fpm.log? Can you acces it?

Edited: 3 years ago#9479

Josh S.
2K Posts
266K Downloads
16 Themes
18 Plugins

Yeah, the 503 without anything showing up in the error.log makes it sound like the issue is in Apache.

After filling the installation form a blank page appears and installation fails. No php errors.

After installation, try removing the .htaccess file. Typesetter attempts to write to the .htaccess file during installation and something may be malfunctioning with it.

3 years ago#9480

juergen
1.4K Posts
51.4K Downloads
16 Plugins
design, web development & visual effects
Could it be this PHP bug?

(Crosspost)
3 years ago#9487

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register