Topic Closed
artem
2 Posts

This is a little awkward: 

There is an outdated website that I need to revive. It is built on Typesetter 1.71. I don't want to rebuild it on a different CMS or do a fresh install before I am sure there is no other way.

Surely, the direct upgrade to 5+ doesn't work. It requires an upgrade to 2.0 first.

Is there a workaround? My ideas are: 

  1. Change the version in the original installation to disable checks. But, I don't know where they are set and I'm quite sure it might not work properly.
  2. Get a copy of 2.0 release first. Is there a chance to get it?

What would you suggest?

9 months ago#11246

juergen
1.4K Posts
51K Downloads
16 Plugins
design, web development & visual effects

Hmm, 1.7 was quite a while ago.
I'd suggest to make a complete backup of the entire site first.

And then maybe just see what happens if you rename the /include directory to /include_1.7 and copy the one from current ver 5.1 over to the server.
Also do the same with /gpconfig.php
edit: And also /.htaccess
This will upgrade the CMS core.

I agree that it will most likely fail but I'd just give it a go.

 

If it doesn't work, here are all major legacy versions:

gpEasy_1.7.2.zip

gpEasy_2.0.zip

gpEasy_2.3.3.zip

gpEasy_2.4.zip

gpEasy_3.0.5.zip

gpEasy_3.5.zip

gpEasy_3.6.zip

gpEasy_4.3.4.zip

gpEasy_4.4.zip

gpEasy_4.5.zip

Typesetter_4.6.1.zip

Typesetter_5.0.zip

 

and finally the current 5.1.1-beta1 master on GitHub.

Good luck

Edited: 9 months ago#11247

artem
2 Posts

juergen,

Thanks for the recommendation :). I have solved it and I was able to update from 1.71 to 5.1 no problem. The main reason to upgrade was that the new server set up (php 7.2) didn't let anyone log into the admin panel.

Here is how I did it:

  • Backed up the site
  • Updated first to 1.7.2 by replacing /include and tried to log on (no luck)
  • Updated to 2.0 by replacing /include and copying over /addons and /themes, then tried to log on (no luck again)
  • Updated the same way to 3.0 and then 5.1, admin panel started working.

The old theme is a little broken, but I think I can fix it. Everything else works fine.

8 months ago#11248

juergen
1.4K Posts
51K Downloads
16 Plugins
design, web development & visual effects

Everything else works fine.

Glad to hear.

The old theme is a little broken, but I think I can fix it.

If you get JS errors (such as '$ is not defined'), Check for <script> elements in template.php <head> section.

As of Typesetter 5, scripts including jQuery will be loaded at the end of the <body> element. If a script in the head section requires jQuery, it will fail and must be loaded/implemented via Typesetter's PHP methods ($page->head_js[] = [script path];, $page->jQueryCode .= [jQuery code];) See here.

8 months ago#11249

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register