Topic Closed
secretary
9 Posts

I originally posted in the Plug-Ins section of this forum because I thought my problem was limited to the "Simple Blog" plug-in. However,  my problem exists with all text content. I am using the three_point_five/Shore theme which has a sidebar. If I type a line longer than the width of the main content section, it appears to wrap correctly while I am editing, and after I publish the page. When I leave the page then re-open the page, the text does not wrap, but runs on across the sidebar.

I have tried several options to fix this. Most have not worked. Some pages I was able to correct by creating them as a separate HTML file using the css: ".hyphens { hyphens: auto;}" and using a <div class="hyphens> to wrap the text, then insert them into the content area of typesetter in an iframe.

In other cases, where I had a short paragraph on a page with other objects (images, etc.) I wrapped the text in a <div style="word-wrap: break-word">text</div>. This worked, but broke the line in some weird places (for example, the word "Use" was broken  into "Us and "e".

Is there any action I can take to resolve this problem for the entire website?

Edited: 8 months ago#11257

juergen
1.4K Posts
51K Downloads
16 Plugins
design, web development & visual effects

What you're describing is not a common or known issue with Typesetter. I can only imagine 2 possible causes:

  1. The way you're transfering your content generates (or keeps existing) non-braking spaces between words. Check the HTML source code for &nbsp; entities and remove them if there are any.
  2. Some rather general CSS rule prevents word-wrapping – namely enforces white-space:nowrap; In this case the guilty rule must be located and neutralized/overruled.

If you have an URL, I'll certainly be able to identify the cause.

edit: A 3rd possibilty could be a strong div.someclass { width:100%; } css rule somewhere.

Edited: 8 months ago#11258

secretary
9 Posts

When I first experienced the problem, I had copied files from a wordpress site, and I though the problem might be resulting from something like you suggest (no breaking spaces). However, Ihave created a fresh page and typed in some text (enough to fill 3 lines). Before I clicked on "Publish Draft" everything looked perfect. As soon as I clicked "Publish Draft" it reformatted itself into one long line which ran over into the sidebar.

Unfortunately, I can't give you a URL to look at because the site is only running on my local computer at present (I just installed Typesetter a few days ago).

Is it possible the problem is with the theme?

 

EDIT: I just took a look at the source code of the page I typed in. CKEditor has replaced EVERY blank space in the text with &nbsp; .  This would appear to be the source of the problem. How do I fix it?

Edited: 8 months ago#11259

juergen
1.4K Posts
51K Downloads
16 Plugins
design, web development & visual effects

CKEditor has replaced EVERY blank space in the text with &nbsp; . 

That's rather strange. While CKEditor replaces multiple blanks with &nbsp; entities, I never encountered single blank replacement with Firefox (Firefox will not even replace Alt+160 inputs with &nbsp; entities, which would be desirable). Chrome/Blink based browsers do that sometimes when pasting text from word processors, but I never encountered it with typed regular blanks.

This would appear to be the source of the problem.

It certainly is.

How do I fix it?

It depends. If all blanks will always get replaced upon saving, we first need to find the source of this behavior. What plugins do you have installed?

As soon as this is fixed, I'd do a search/replace of "&nbsp;" => " " in all files in /data/_pages/, /data/_extra/ and /data/_addondata/ (the latter for SimpleBlog posts) and the respective subdirs. Notepad++ and many other code editors can do that.

 

Edited: 8 months ago#11260

secretary
9 Posts

The only plugins I have installed are "Simple Blog", "Simple Event Calendar", and "Simple Button".

The following is the source code I got when I typed in a heading followed by a single line of text:

<div>
<h2>Test&nbsp;hyphens</h2>
This&nbsp;is&nbsp;a&nbsp;page&nbsp;that&nbsp;I&nbsp;typed&nbsp;in&nbsp;right&nbsp;after&nbsp;creating&nbsp;it.&nbsp;I&nbsp;did&nbsp;not&nbsp;copy&nbsp;it&nbsp;from&nbsp;anywhere.&nbsp;I&nbsp;just&nbsp;typed&nbsp;until&nbsp;it&nbsp;wrapped&nbsp;onto&nbsp;several&nbsp;lines,&nbsp;then&nbsp;I&nbsp;clicked&nbsp;on&nbsp;&quot;Publish&nbsp;Draft&quot;.&nbsp;Up&nbsp;to&nbsp;that&nbsp;point,&nbsp;it&nbsp;wrapped&nbsp;perfectly,&nbsp;but&nbsp;when&nbsp;I&nbsp;viewed&nbsp;it&nbsp;after&nbsp;publishing&nbsp;it&nbsp;the&nbsp;text&nbsp;overflowed&nbsp;into&nbsp;the&nbsp;sidebar.</div>

I have searched on the web, and there are ways to stop ckeditor from inserting ANY non-breaking spaces by changing configuration settings. I am not familiar enough with ckeditor configuration files or javascript, so I have no idea how to change those settings.

Other than this problem, I really like Typesetter so I am anxious to solve this.

8 months ago#11261

secretary
9 Posts

I believe I have found the problem. Of course it was me, not Typesetter!

Apparently, I must have edited the styles.css file in the theme's folder and somehow messed it up. Today, I replaced it with a copy from a fresh download. The non-breaking spaces are no longer being inserted by CKEditor.

When I originally started using Typesetter, I was cutting and pasting blog pages from Wordpress. I'm guessing there was a problem (i don't remember what) that I thought I could solve by editing the css. Obviously, I created a problem instead of solving one. Now I just have to clean up any files that are full of non-breaking spaces.

Juergen, Thank you for you patience and help. I will try to be not quite so ignorant in the future.

8 months ago#11262

juergen
1.4K Posts
51K Downloads
16 Plugins
design, web development & visual effects

"Simple Blog", "Simple Event Calendar", and "Simple Button"

None of them messes with CKEditor configuration, so I'm a bit clueless where the &nbsp; come from.
Do they already exist when you switch to "Source" mode in CKEditor right after you input some text (don't think so).

So here's some guesswork:

  • Do you have HTMLtidy installed on your server and enabled it in Typesetter Configuration? If so try to disable it.
  • Maybe also try different browser (FF 60 was still shortly after their "Quantum" overhaul and I remember it had some minor bugs then, but nothing you encounter)
8 months ago#11263

juergen
1.4K Posts
51K Downloads
16 Plugins
design, web development & visual effects

I believe I have found the problem...

Oh... well, glad you found it and there is nothing that needs to be fixed ;) We never can be completely sure.

8 months ago#11264

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register