Topic Closed
jogai
264 Posts

When editing text there is sometimes an empty paragraph added, if the user adds an extra return for example. Can this behaviour be changed? I'd like the paragraphs stripped if they have are only this: <p>&nbsp;</p>

 

7 years ago#3504

Josh S.
2K Posts
263K Downloads
16 Themes
18 Plugins

...I thought this was a bug with CKEditor at first, but it could be a mistake we made with one of the CKEditor settings. We have the following setting in the /include/js/ckeditor_config.js file

config.ignoreEmptyParagraph = false;

It should be set to true so that CKEditor doesn't create <p>&nbsp;</p> when the page is empty.

Edited: 7 years ago#3511

jogai
264 Posts

Good to see this as default in the new release. And thank you of course for the new 2.4!

7 years ago#3624

Josh S.
2K Posts
263K Downloads
16 Themes
18 Plugins

No problem!

7 years ago#3627

jogai
264 Posts

Does anyone know a setting that disables adding a style attribute when inserting an image?

The problem is this

	  style="width: 255px; height: 276px;"

gets inserted. But that doesnt play nice with the aspect ratio of fluid images.

7 years ago#4228

Eric
193 Posts
1.4K Downloads
1 Themes

Simply delete the measurements in the Image Properties dialog box.

You could also modify ckeditor_config.js to change that behavior. Use this thread as a starting point. Another reason to add support for a custom ck config outside the include folder.

7 years ago#4233

Topic Closed

 

News

Typesetter 5.1
8/12/2017

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress
5/3/2016

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register