Posts by: juergen

Posts: 1379
Post: 11280
Topic: Subdomain installation problem

Please avoid multiple CMS installations in nested directory structures.
.htaccess directives inherit their rules to subdirectories which most likely causes your issues.

Try to configure the hosts in a way that the main domain's (www / no subdomain) document root points to a seperate directory on the webhost, similar to the festival subdomain.

  /www/[main site Typesetter installation]
  /festival/[festival siteTypesetter installation]

I myself always organize my webspaces like that, includig directories for the main domains.


edit: once the host config is changed you can simply move the main site installation to it's new directory.

Edited: 6 days ago
Post: 11274
Topic: hide in page edit buttons on menus

It's rather tricky to hide the edit overlay for specific elements (because it's generated based on area enumeration and positioned dynamically upon JS events), but…

You could give my HideAdminUI plugin a go. When installed, you may always toggle all Admin UI elements by pressing [Ctrl] + [H] or  clicking the (-) icon at the top left of the viewport.

Edited: 3 weeks ago
Post: 11272
Topic: Can't edit galleries


please try to add a class attribute to the gallery section via 'Manage Sections' (editor's 'Page' mode) -> [the respective gallery section] -> Options icon.
Then check if the gallery section is editable again. The class name itself doesn't matter (just use anything like 'gallery1234').


FYI: I believe it's related to this fix, but I'm not completely sure.
If so, newly created galleries should be editable (just legacy sections lacking attributes were affected)

3 weeks ago
Post: 11267
Topic: Fatal error — Uncaught Error

Looks like a bug. Please try to change line 273 in /include/admin/Menu/Tools.php


                $type = '';


                $type = array();
3 weeks ago
Post: 11264
Topic: Word Wrap

I believe I have found the problem...

Oh... well, glad you found it and there is nothing that needs to be fixed ;) We never can be completely sure.

4 weeks ago
Post: 11263
Topic: Word Wrap

"Simple Blog", "Simple Event Calendar", and "Simple Button"

None of them messes with CKEditor configuration, so I'm a bit clueless where the   come from.
Do they already exist when you switch to "Source" mode in CKEditor right after you input some text (don't think so).

So here's some guesswork:

  • Do you have HTMLtidy installed on your server and enabled it in Typesetter Configuration? If so try to disable it.
  • Maybe also try different browser (FF 60 was still shortly after their "Quantum" overhaul and I remember it had some minor bugs then, but nothing you encounter)
4 weeks ago
Post: 11260
Topic: Word Wrap

CKEditor has replaced EVERY blank space in the text with   . 

That's rather strange. While CKEditor replaces multiple blanks with   entities, I never encountered single blank replacement with Firefox (Firefox will not even replace Alt+160 inputs with   entities, which would be desirable). Chrome/Blink based browsers do that sometimes when pasting text from word processors, but I never encountered it with typed regular blanks.

This would appear to be the source of the problem.

It certainly is.

How do I fix it?

It depends. If all blanks will always get replaced upon saving, we first need to find the source of this behavior. What plugins do you have installed?

As soon as this is fixed, I'd do a search/replace of " " => " " in all files in /data/_pages/, /data/_extra/ and /data/_addondata/ (the latter for SimpleBlog posts) and the respective subdirs. Notepad++ and many other code editors can do that.


Edited: 4 weeks ago
Post: 11258
Topic: Word Wrap

What you're describing is not a common or known issue with Typesetter. I can only imagine 2 possible causes:

  1. The way you're transfering your content generates (or keeps existing) non-braking spaces between words. Check the HTML source code for   entities and remove them if there are any.
  2. Some rather general CSS rule prevents word-wrapping – namely enforces white-space:nowrap; In this case the guilty rule must be located and neutralized/overruled.

If you have an URL, I'll certainly be able to identify the cause.

edit: A 3rd possibilty could be a strong div.someclass { width:100%; } css rule somewhere.

Edited: 4 weeks ago
Post: 11256
Topic: Always redirect to https — how to?

Assumimg that your webserver is Apache:

Open the file [Your Typesetter installation directory]/.htaccess

If it already contains a <IfModule mod_rewrite.c> block (most likely the case), add the following 2 lines

  RewriteCond %{SERVER_PORT} 80
  RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [L,R=301]

right after

  RewriteEngine On


otherwise add this whole block:

<IfModule mod_rewrite.c>

  RewriteEngine On

  RewriteCond %{SERVER_PORT} 80
  RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [L,R=301]

Edited: 4 weeks ago
Post: 11249
Topic: Upgrading from 1.71 to 5+

Everything else works fine.

Glad to hear.

The old theme is a little broken, but I think I can fix it.

If you get JS errors (such as '$ is not defined'), Check for <script> elements in template.php <head> section.

As of Typesetter 5, scripts including jQuery will be loaded at the end of the <body> element. If a script in the head section requires jQuery, it will fail and must be loaded/implemented via Typesetter's PHP methods ($page->head_js[] = [script path];, $page->jQueryCode .= [jQuery code];) See here.

1 month ago


Typesetter 5.1

Typesetter 5.0.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

Over 8 Times Faster Than Wordpress

We've known for a long time that Typesetter is fast. It's something we take pride ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In