Topic Closed
vassya
4 Posts

Hello! Trying to follow installation guide, but met an unexpected problem.

1) Accessing index.php, checking, all fine (including 777 on /data) : http://itmages.ru/image/view/1017486/4ed4cd01

2) Installation, seemingly went fine too : http://itmages.ru/image/view/1016875/1b2ec48f

3) And error itself : http://itmages.ru/image/view/1016874/7d0a5631

Tried several folders, still the same error. :( I understand that it's hard to guess error's origin due to variety of servers settings, but any hint on what should I look into is appreciated!

8 years ago#5898

Josh S.
2K Posts
296K Downloads
16 Themes
18 Plugins

Hi Vassya,

I haven't seen that happen on a fresh install before. It can be traced back to the $config['gpversion'] value so I would look at the contents of your /data/_site/config.php file. It should have an array similar to this:

$config = array (
  'language' => 'en',
  'toemail' => '---your email---',
  'gpLayout' => 'default',
  'title' => 'My gpEasy CMS',
  'keywords' => 'gpEasy CMS, Easy CMS, Content Management, PHP, Free CMS, Website builder, Open Source',
  'desc' => 'A new gpEasy CMS installation. You can change your site\'s description in the configuration.',
  'timeoffset' => '0',
  'langeditor' => 'inherit',
  'dateformat' => '%m/%d/%y - %I:%M %p',
  'gpversion' => '3.6',
  'passhash' => 'sha1',
  'gpuniq' => 'UPCWKihdWBcqwKU9hxox',
  'combinecss' => true,
  'combinejs' => true,
  'etag_headers' => true,
);

 

8 years ago#5899

vassya
4 Posts

Hi Josh, thanks for quick reply. Array is virtually the same, except 'gpversion', also has this :

<?php
defined('is_running') or die('Not an entry point...');
$fileVersion = '4.0RC2';
$fileModTime = '1368006125';
$file_stats = array (
'created' => 1368006125,
'gpversion' => '4.0RC2',
'modified' => 1368006125,
'username' => false,
);

Tried version 3.6, same error :( Log file shows a vast amount of errors, all similar :

PHP Notice: Undefined index: gpversion in /home/include/common.php on line 1738
PHP Notice: Undefined index: gpversion in /home/include/tool/upgrade.php on line 14 etc.

8 years ago#5901

Josh S.
2K Posts
296K Downloads
16 Themes
18 Plugins

Strange. Will you upload this common.php file to your server to see what message it outputs?

Note: This common.php file is for testing and should only be used with gpEasy 4.0rc2.

8 years ago#5902

vassya
4 Posts
Oh well, I can't even download that php file, sorry. Gives out error : Invalid Request (6: /htdocs/data/_addondata/x_Addons/user/1/7/common.gpa)
8 years ago#5905

Stano
483 Posts
16.6K Downloads
1 Themes
1 Plugins

Hello, i remember to see this upgrade message far in the past and then helped me "cleaning a browser cache" (in Firefox via Ctrl+Shift+Del). Maybe it's abs. out of topic here, but who knows? :-)

8 years ago#5906

Josh S.
2K Posts
296K Downloads
16 Themes
18 Plugins
Sorry about that. The download should work now.
8 years ago#5907

vassya
4 Posts

Common.php placed in the root gives "Not an entry point...".

Installation itself now changed error to "gpversion not set (1)".

Probably specific hosting error or I screwed up somewhere during the installation. : ( But anyway thanks Josh & Stano for help.

8 years ago#5908

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register