Topic Closed

Hi,

After I signed in to the admin page 'http"//mydomain.com/Admin' I got this error message:

"Warning: Cookies are required to continue. Refresh this page if you have cookies enabled."

I tried different browsers and I checked cookes are allow for all web sites.

Any ideas?

Thanks.

11 years ago#584

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

try and clear your cache

if that doesn't do it then delete cookies, clear cache, clear history, clear everything except passwords and saved form data.

It is odd that it's happening on multiple browsers. double check that your site is allowed to set a cookie--add it to the exceptions list.

11 years ago#589

I tried clear everything and the result is the same. I tried on different computes with different browsers but still no luck.

I am not sure whether is browser problem or not. I followed this link to create my .htaccess when I tried to remove index.php from the URL. Also many web sites won't allow me to access if I don't enable cookies.

http://docs.gpeasy.com/index.php/Main/mod_rewrite%20and%20index.php

 

Thanks.

 

11 years ago#590

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

did your gpEasy install work before enabling .htaccess?

If so then you know where the problem is--in your htaccess file--start with the example file and go from there. Remember you also have to edit the index.php file and change the setting to your directory.

If not. . . try and disable htaccess and see if it works. If that doesn't work you can always try a fresh install and make sure it works before doing anything else, then do your htaccess. etc--always backtrack to where it was working. If a fresh install doesn't work then it most likely is not gpEasy.

Other possibilities. . . are you behind some type of restricted firewall or something?

If you are getting problems form other sites as well then it could be something to your router or firewall. Generally cookies are rather straight forward. You can always download a portable browser from portableapps.com and test that. With that you will eliminate any user account issues with the computer you are on, but you've tried other computers. . . so, it seems rather strange.

11 years ago#591

Hi,

This is what I tested so far.

-delete all the folders and files on my server

-re-upload everything to the root of my server

-I can setup my admin user name and password and change permission on data folder

-after that the link to my server becomes http://mydomain/index.php/index.php/Admin

-all the CSS format are gone but I did not get the cookies problem

-rename .htaccess_example to .htaccess on the server

-the link is still pointing to http://mydomain/index.php/index.php/Admin but I got the cookies problem

-made changes according to this link http://docs.gpeasy.com/index.php/Main/mod_rewrite%20and%20index.php

-the link becomes http://mydomain/Admin (which I want) and I still get the cookies problem

I can access other sites from my computer and I don't think it is the firewall problem. I have tried to access the web site from 2 different locations and still got the cookies problem.

Thanks.

11 years ago#599

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

I have to say your problem is rather odd.

What software is your server host using? Do they use CPanel/apache or what? Do they have the correct version of PHP you need  (PHP 4.1 or greater)?

From the sound of it, you have not been able to get gpEasy installed and working properly at all, correct? I mean, everything is working correctly before doing any mods. This sounds like a server problem.

You are getting the cookie problem before mod rewrite is even working for gpEasy thus I'm inclined to think this is your server. In order for mod rewrite to be working you have to edit the index.php file, thus while you put the .htaccess file in it doesn't really matter because gpEasy will ignore it until the index.php is changed. Furthermore, your formatting is broken on a fresh install--that's shouldn't happen.

Other options for now

Try a loclhost install onto your computer with xampp or xampplite. Follow method 2: 

http://www.apachefriends.org/en/xampp-windows.html#521

for an easy way to install xampp. Then just put the gpEasy install into the htdocs folder inside xampp and install normally.

I'll try and write a tutorial for installing with xampp tomorrow in the wiki docs.

The tutorial is up under installation in the documentation.

Right now all I can think is that your server doesn't have the required php version.

Edited: 11 years ago#607

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register