Topic Closed
tzych42
2 Posts

Hi, just installed gpEasy, but I'm having a timeout error issue.  When I try to load the home page, I get the following error:

Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/gpeasy/include/thirdparty/less.php/Less.php on line 4869

If I try to go to the login page, I get the same error.  It also says my browser is not supported.  Environment is as follows:

Server:

Raspberry Pi running Raspian (Debian Wheezy), Apache 2.2.22, PHP 5.4.4, gpEasy 4.3.1; everything is up-to-date

Client (from local network):

OS X 10.5.8 running Firefox 25.0.1, javascript enabled

Any thoughts on what I can try?

- Tom

7 years ago#6893

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/gpeasy/include/thirdparty/less.php/Less.php on line 4869

Hmm. Less.php would be the likely culprit, but I'm still surprised.

The easiest way to get going would be to prevent the less compiler from executing. You could rename the /themes/Bootswatch_Flatly/4_Sticky_Footer/style.less file to style_backup.less

7 years ago#6898

tzych42
2 Posts
Thanks Josh. That did get rid of the less.php error and the page loads in a more acceptable time. However, I still can't log in. I know I'm entering the right password, but it doesn't accept it. If I try to have it send me a new password, it says "Oops, that didn't work, please try again." I don't believe I have a mail server running on the Pi, so that could be the issue there. My browser received one cookie: name "g", contents "2". I don't see any error logs. Is there any other info that would help? - Tom
7 years ago#6900

DareNow
2 Posts

I have the exact same issue on a raspberry Pi web server.

 

I'll check if this is related just with rPi, or is an issue with gpEasy 4.3

LE: on my other server where i had already multiple instances of previous gpEasy, i cannot install this new version due to memory limit requirements of 96+...right now on my server i have 64...

Why the new version need more memory and why cannot be used on a light server, such as rPI? My chose of this CMS was based on the light resources...

Edited: 7 years ago#6946

feniweb
298 Posts
I had the problem with 5.2.x *. Less insufficient memory under PHP 5.3.x PHP I had the problem no longer says the Proveder the memory management under PHP 5.3.x is better regulated. Since the compiler for *. Less resources very hungry.
7 years ago#6947

Eric
193 Posts
1.6K Downloads
1 Themes
DareNow, did you try Josh's workaround to prevent LESS compiling?
7 years ago#6948

DareNow
2 Posts
Hadn't try the workaround, but even if let's say the LESS issue will disappear, I'm still unclear with memory limit requirements, as I've installed multiple old versions on the same servers and hadn't any issue
7 years ago#6949

Eric
193 Posts
1.6K Downloads
1 Themes

LESS compiling is definitely what's driving up memory use. I wish it were set up as an option that could be turned on or off. And I'm sure that, with hindsight, Josh wishes he set it up that way too. I haven't looked at the code so I don't know what would be involved in separating the LESS compiler from core functions, but I'd put it on my wish list.

If it is separate, you'd end up with different memory requirements whether or not you activate the LESS compiler. That may also confuse some users.

7 years ago#6950

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Sorry to hear the less compiler is causing you all problems. It was tested on a number of different server configurations by many users and things looked good when the final release was made. Unfortunately, as you all know too well, the testing wasn't thorough enough.

I am pretty excited about the features available to us with less.php. It opens up a world of possibilities for gpEasy themes and customization. Though, in order for it to be helpful, it has to actually work...

I've invested a fair amount of time optimizing the less compiler (In tests with bootstrap, memory usage is down from 67MB to 37MB with similar speed improvements). At this point, I've tested it on all my dev servers but I'd love to have additional results. If anyone else would like to test it out, it can be downloaded here: github.com/oyejorge/gpEasy-CMS/releases/

7 years ago#6951

fly06
263 Posts
19.7K Downloads
1 Themes
8 Plugins

Hi Josh,

I would be happy to test the latest version but what specific tests would you like us to perform?

Btw, one solution to this performance problem would be porting Less.php to C and create a Php extension.

I am sure you'll love the idea.

;-)

 

 

7 years ago#6956

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Thanks fly06,

what specific tests would you like us to perform?

Basic installation. A number of users were getting blank screens during installation and I'd like to know if the new version of less.php has fixed it (I made some additional changes to gpEasy since the latest beta release that specifically address the blank screen issue and I'll put together a second beta release soon).

Btw, one solution to this performance problem would be porting Less.php to C and create a Php extension.

I like the idea, but it would be a pretty big project.

7 years ago#6957

fly06
263 Posts
19.7K Downloads
1 Themes
8 Plugins

I have installed it on my laptop and everything has been going well so far.

Linux Xubuntu 13.04, lighttpd/1.4.31, Php 5.4.9

I am wondering if the problems described above could actually come from the machine (R-Pi)?

If a R-Pi machine is 3 times slower than a standard desktop/laptop machine than a max_execution_time of 30 seconds on a R-Pi corresponds to a max_execution_time of 10 seconds on a standard desktop/laptop machine (and probably far less on a high performance server machine)...

7 years ago#6959

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register