Topic Closed
14 Posts

I followed the various information to set up gpeasy with nginx (though this was for version 3 gpeasy) linked elsewhere in these forums.  I tried inserting "


as well into gpconfig.php though I don't know if that works anymore.

Anyway, I could access and change most config settings, but I could not edit pages.  When I click edit with debug turned on I get this:

thrownError = SyntaxError: missing ) in parenthetical

with debug off:

There was an error processing the last request. Please reload this page to continue.

If you look in your nginx log and see something like:
open() "//var/lib/nginx/tmp/fastcgi/1/01/0000000011" failed (13: Permission denied) while reading upstream

your problem is coming from permissions being wrong on /var/lib/nginx which need to be set to the user and group nginx runs under.

I don't know if anyone else will have this problem, but if editing is not working, dig deeper into nginx logs and see if this isn't at the root.

9 years ago#6982

264 Posts

It looks you solved the problem the wrong way around. Your webdirectory needs to permit the nginx user to modify the file.

I've a script for setting up vhosts in nginx for gpEasy:

Edited: 9 years ago#6985

14 Posts
I've got the permissions also set right.  I think the error I had may have come from some permission changes during an upgrade to nginx.

I like your script.  Everytime I've copied-pasted-edited nginx config files, manually set up mysql (usually for drupal up to now), I've thought how I ought to have some script to do it...
9 years ago#6988

264 Posts
No problem, I forked it also and edited only a few lines.
9 years ago#6990

Topic Closed



elFinder 2.1.50 in Upcoming Release

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

Log In