Topic Closed
mrplayboy
59 Posts

Hey,

 

first of all: Great software! Installed it on XAMPP and really like this simplicity and good overview!

Just the right thing for me... :-)

 

To my problem:

Wanted to install the latest, stable version (i think 1.63) on my webspace, where safemode is on (can't turn it off, because provider doesn't want to turn it off). So, I entered all the details needed, but it said, that it can't write "pages.php".

Tried it several times, didn't work.... so, my idea was to install it local on XAMPP (no safe mode on) and then to transfer the whole directory. So, the page is uploaded and looks like on the local server, but I can't login with the admin name and password I logged in on the local server :-( - So I tried to let me sent the password via email - then it said, that my user "%s" doesn't exist :-(

So my questions to you guys are:

1.) How can I install the software with safe-mode on and the  pages.php-problem above?

2.) Or even better: How I can I solve the problem with the admin user and password, then problem 1) wouldn't disturb me anymore.

 

Would be really great, if you could help me (please as detailed as possible, cause I am a really noobie...).

Thanks in advance for all your help and time in advance - I appreciate it!

 

 

EDIT: Problem No. 1 in my post is exactly like this one:

http://www.gpeasy.com/Special_Forum?show=t52

and no: I don't have this subfolders :-(

 

---------------------------------------------------

Maybe it helps, here are the server configuration details:

 

PHP Version 4.4.8-pl0-gentoo

System Linux www 2.6.31-gentoo-r6-comtrance #2 SMP PREEMPT Mon Jan 11 17:36:47 CET 2010 i686 Build Date Jul 2 2008 21:39:47 Configure Command './configure' '--prefix=/usr/lib/php4' '--host=i686-pc-linux-gnu' '--mandir=/usr/lib/php4/man' '--infodir=/usr/lib/php4/info' '--sysconfdir=/etc' '--cache-file=./config.cache' '--disable-cli' '--with-apxs2=/usr/sbin/apxs2' '--with-config-file-path=/etc/php/apache2-php4' '--with-config-file-scan-dir=/etc/php/apache2-php4/ext-active' '--without-pear' '--enable-bcmath' '--without-bz2' '--disable-calendar' '--with-curl' '--disable-dbase' '--with-dom' '--enable-exif' '--without-fbsql' '--without-fdftk' '--enable-filepro' '--enable-ftp' '--with-gettext' '--without-gmp' '--without-hwapi' '--with-iconv' '--without-informix' '--without-kerberos' '--enable-mbstring' '--without-mcal' '--with-mcrypt' '--without-mcve' '--disable-memory-limit' '--without-mhash' '--with-ming' '--without-mnogosearch' '--without-msql' '--without-mssql' '--with-ncurses' '--without-oci8' '--without-oci8-instant-client' '--without-oracle' '--with-openssl' '--with-openssl-dir=/usr' '--disable-overload' '--disable-pcntl' '--without-pfpro' '--without-pgsql' '--disable-posix' '--without-pspell' '--without-recode' '--disable-shmop' '--with-snmp' '--disable-sockets' '--without-sybase' '--without-sybase-ct' '--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm' '--disable-tokenizer' '--disable-wddx' '--with-xmlrpc' '--with-zlib' '--disable-debug' '--enable-dba' '--without-cdb' '--with-db4' '--without-flatfile' '--with-gdbm' '--without-inifile' '--disable-dbx' '--with-freetype-dir=/usr' '--with-t1lib=/usr' '--disable-gd-jis-conv' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--without-xpm-dir' '--with-gd' '--with-imap' '--with-imap-ssl' '--with-mysql=/usr' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-readline' '--without-libedit' '--enable-xslt' '--with-xslt-sablot' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--without-mm' Server API Apache 2.0 Handler Virtual Directory Support disabled Configuration File (php.ini) Path /etc/php/apache2-php4/php.ini Scan this dir for additional .ini files /etc/php/apache2-php4/ext-active PHP API 20020918 PHP Extension 20020429 Zend Extension 20050606 Debug Build no Zend Memory Manager enabled Thread Safety disabled Registered PHP Streams php, http, ftp, https, ftps, compress.zlib

Configuration

PHP Core

Directive Local Value Master Value allow_call_time_pass_reference On On allow_url_fopen Off Off always_populate_raw_post_data Off Off arg_separator.input & & arg_separator.output & & asp_tags Off Off auto_append_file no value no value auto_prepend_file no value no value browscap no value no value default_charset no value no value default_mimetype text/html text/html define_syslog_variables Off Off disable_classes no value no value disable_functions no value no value display_errors On On display_startup_errors Off Off doc_root no value no value docref_ext no value no value docref_root no value no value enable_dl On On error_append_string no value no value error_log no value no value error_prepend_string no value no value error_reporting 2039 2039 expose_php On On extension_dir /usr/lib/php4/lib/php/extensions/no-debug-non-zts-20020429 /usr/lib/php4/lib/php/extensions/no-debug-non-zts-20020429 file_uploads On On gpc_order GPC GPC highlight.bg #FFFFFF #FFFFFF highlight.comment #FF8000 #FF8000 highlight.default #0000BB #0000BB highlight.html #000000 #000000 highlight.keyword #007700 #007700 highlight.string #DD0000 #DD0000 html_errors On On ignore_repeated_errors Off Off ignore_repeated_source Off Off ignore_user_abort Off Of

Edited: 11 years ago#691

cyberman
85 Posts
1.5K Downloads
1 Plugins

Have you tried to set gpdebug inside index.php to true? Any results?

By the way - your provider uses a very old php verson. PHP 4.4.8 is released on 2008-1-3 (and a lot unsecure). Maybe yoou should change your provider ...

11 years ago#692

Caps
87 Posts

Yes, change providers. Most will have safe_mode=off. Most CMS scripts will require safe mode to be off.

Edited: 10 years ago#1092

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register