Topic Closed

In home page of your CMS, there's a text that says, it needs PHP 4.* , however, it isn't true (just fix it please).

 

I have 5.2.* version of PHP on my hosting which is not compatible with never versions of gpEasy CMS. I just get this error after installation:

 

Warning (2)
file_exists(): open_basedir restriction in effect. File(/usr/local/apache/htdocs/fonts.googleapis.com/css?family=Lato:400,700,900,400italic) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp)
    in: /home/a2267246/public_html/include/thirdparty/less.php/Less.php
    on line: 5499
    Request: /
    Method: GET
Show Backtrace

 

What is that?

6 years ago#7843

juergen
1.5K Posts
58.4K Downloads
16 Plugins
design, web development & visual effects

Hi nikola,

welcome to the forum!

As the error says, it seems that open_basedir restriction is configured by your hosting provider so gpEasy's LESS compiler may not access the fonts from Google CDN.

You could try the following:

  1. open the file /themes/Bootswatch_Flatly/Bootswatch/bootswatch.less with your text editor.
  2. comment out line 5 by prefixing it with two slashes so it looks like this:
    // @import url("//fonts.googleapis.com/css?family=Lato:400,700,900,400italic");
  3. save and close the file.
  4. open the file /themes/Bootswatch_Flatly/4_Sticky_Footer/template.php
    and insert the following line after line 12:
    <link href='http://fonts.googleapis.com/css?family=Lato:400,700,400italic,900' rel='stylesheet' type='text/css'>
  5. save and close the file.
  6. refresh your website in the browser.

It you want to use a different Bootswatch theme/layout you will have to change the files in the respective theme directories.

I hope this will work and there are no other errors caused by the open_basedir restriction.

You could also ask your service provider support to disable the open_basedir restriction. Maybe you can even configure it yourself via the hosts config panel (unlikely).

 

Edited: 6 years ago#7844

juergen
1.5K Posts
58.4K Downloads
16 Plugins
design, web development & visual effects

In home page of your CMS, there's a text that says, it needs PHP 4.* , however, it isn't true (just fix it please).

Where exactly did you find this info about PHP4?
I only know this page http://gpeasy.com/Docs/Installation which says gpEasy needs PHP 5.2+.

6 years ago#7845

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register