Topic Closed
maxworks67
7 Posts

Hi there!

Firstly, would like to say that I love this CMS. Wish I had the technical savvy to be able to contribute. Am looking forward to a stabe 1.7 release.

My problem is that I have been playing with test sites. There are two issues that I have (both in 1.6 and 1.a7.xxx)

1) Didn't get the prep page to begin with When I prep the site for delete it works... but I didn't do it before, and rather than having: Group =32081 / Owner=583 showing for the folders contained in /data

I have: Group=99 / Owner = 99

In the latter case it is quite simply impossible to delete the /data directory and everything below it from the server - this is true whether I try with FireZilla or through cpanel

2) Transferring from a localhost test site to a server Is there anyway to transfer a site form localhost to an external webserver? When I try my login details are no longer valid - and then I have the problem as listed in 1) above?

Sorry if I'm asking dumb questions.

Anyway, keep up the amazing work. You are well on the way to creating THE CMS that people are going to want to use.

10 years ago#715

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

Since no one with more server expertise answered I guess I'll give it a shot. From what I found on Google if you are stuck with 99 and on a shared server you will need to submit a support ticked to get the folders deleted. 

Make sure when you create folders in the future that you have the ability to define the security levels for them. If your server for some reason makes this difficult then you might want to look for a better server. 

Transferring from a localhost is no big deal. Use Filezilla or WinSCP. The later has a "sync" function you can use. As far as your problems go with connecting to your server. . . that could be a lot of things. They should have some info on how to setup an FTP client--double check to make sure it's setup correctly. If you still have problems I suggest you speak with someone running your server.

The problems you are having are on your server side of things not gpEasy. What you are basically looking at is,

  1. making sure you have the correct security on folders before installing gpEasy
  2. making sure you have the correct connection info for your server

And since I'm no expert on all types of servers I don't have anything more. . . sorry.

10 years ago#722

geckojsc
2 Posts

My host has a 'Fix File Ownership' button which will sort out problems like this. If your host doesn't have this, you might want to try some sort of PHP file manager, because it looks like PHP is causing the problem, but PHP can fix it!

[edit] I don't recommend fiddling with the file ownership unless you want to uninstall gpEasy. You may encounter problems. gpEasy has an 'uninstall prep' page which will set all permissions 777 (read, write, execute - for all). If you want to modify/delete a few files via FTP, you probably want to enable this option, then revert it back when you're done.

Edited: 10 years ago#773

maxworks67
7 Posts

First question and reply

Thanks for your help. However, I would like to note that the owner permissions were changed at some time after installation - and without my intervention via either cpanel or FileZilla. That is to say that I had a working site with the correct read/write accesses.

I am pretty sure that the problem happened when I tried to delete a test site using 1.7ax and had not yet realised that I should prepare for deletion from within the admin panel.

The same problem does not happen with 1.6x - but it happens with every 1.7ax installation I have tried.

I absolutely adore this CMS - and am certain that I will stay with it, as it certainly does what I want it to do.

Second question

I still don't have an answer as to why a site tested and created on my machine with xampp cannot be uploaded to my server. Whilst the content shows up, the admin logins are lost. Does anyone have an idea. I live in Africa and the average upload/download speed are 15kb / 7kb so it really it MUCH easier to edit and create locally rather than over the Internet at the moment.

Thanks Josh et al for this fantastic CMS

10 years ago#789

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

For the first problem I suggest you fill out a bug report. Personally I don't remove gpEasy from within gpEasy. I use a FTP client and just delete the folders. See the contact page here for where to report bugs.

Because each server is different it's hard to say what the cause of your problems.

Second problem. Check out my gpEasy Tutorials page. I have a page there on xampp, installing gpEasy in xampp or server, and sync gpEasy xampp install with server with WinSCP.

I sync my xampp local install with my server and have had no problems as far as that is concerned. In fact that's how I "installed" my sites on the server, I just uploaded the entire xampp installation of gpEasy and it was working fine. And yes, it's 1.7a4.

Hope that helps.

10 years ago#791

maxworks67
7 Posts

Thanks for getting back to me... I'll list the problem as a bug, as I have full always had full control over my files on the server I am using (for the last 8 years). Deletion of these files is impossible whether I use cpanel or FileZilla. The permissions ahve been changed during editing whilst logged in as Admin. Anyway - it's an awesome CMS :) thanks for all the work.

10 years ago#809

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register