Topic Closed
hoghoj1
179 Posts
HH-Support

Using Extreme Surfing theme with working submenus, they disappeared when i upgraded from 4.3.4 to newest 4.5 version!

How do I get them back, or is there a way to downgrade the site again?

Please help as soon as possible?

hoghoj1

5 years ago#7914

juergen
1.4K Posts
53.1K Downloads
16 Plugins
design, web development & visual effects

Hi hoghoj1,

gpEasy since version 4.4 uses jQuery 1.11.

Extreme Surfing and some other themes from Dominion IT use jquery.dropotron-1.0.js which is not compatible with jQuery 1.11 anymore.

Fortunately the fix is easy:

  • Download the current version of jquery-dropotron (1.4.3) from gitub
  • Extract  jquery.dropotron.min.js into your /themes/ExtremeSurfing directory
    (or /data/_themes/[a random string] if the theme was installed directly via gpEasy's built.-in "Find Themes" feature)
  • Edit settings.php in your theme directory and change line 7 from
  • $page->head_js[] = $themeDir.'/jquery.dropotron-1.0.js';
  • to
  • $page->head_js[] = $themeDir.'/jquery.dropotron.min.js';

That's it.

 

 

BTW: It's always a good idea to have a look into the theme's Support Forum ;o)
I just wanted to post this fix there and - guess what - we already addressed the issue 3 month ago there :-)

Edited: 5 years ago#7915

hoghoj1
179 Posts
HH-Support

Hi Juergen,

and thanks for a fast reply - I was looking for a similar error in the forum, but didn't find it :-( - but I made the corrections, and this happened instead:


type Parsing Error (4)
message syntax error, unexpected '$themeDir' (T_VARIABLE)
file /customers/e/5/e/billardsf.net/httpd.www/billard-fo/data/_themes/mhee4aa/settings.php line 1
request /billard-fo/
addon_name
addon_id 178
time 1439674797
request_method GET

Tried to reverse corrections in Settings.php and reload, and this came up:

Warning: A component of this page has been disabled because it caused fatal errors:
Enable Component   Show Backtrace

array(
   [type] => (integer)4
   [message] => (string)syntax error, unexpected '$themeDir' (T_VARIABLE)
   [file] => (string)/customers/e/5/e/billardsf.net/httpd.www/billard-fo/data/_themes/mhee4aa/settings.php
   [line] => (integer)1
   [request] => (string)/billard-fo/
   [addon_name] => (NULL)
   [addon_id] => (string)178
   [time] => (integer)1439713355
   [request_method] => (string)GET
   [file_modified] => (integer)1439713331
   [file_size] => (integer)270

As I can see it, the error may be found in the fact, that (I can't remember the reason for doing so, I think something about an old wish to have the national .fo, but ended up with .net) the entire website is put into a subdirectory called "billard-fo" between "addons" and "data".

How can I fix this ??

 

5 years ago#7918

juergen
1.4K Posts
53.1K Downloads
16 Plugins
design, web development & visual effects

Hmm, it looks as if you have a syntax error in the settings.php now.

Let' simplify this and get rid of settings.php
(actually I myself never use settings.php and don't know when it's going to be loaded and if the needed variable $page is already global here, however…)

  1. Rename or remove settings.php
  2. Paste the following lines into template.php after line 22 (which should read <?php gpOutput::GetHead(); ?> if you have'nt changed template.php)
<?php 
global $page;
$page->head_js[] = dirname($page->theme_path) . '/jquery.dropotron.min.js';
?>

This should do the trick.

If you still see the warning…
Warning: A component of this page has been disabled because it caused fatal errors:
Enable Component   Show Backtrace

… click "Enable Component"

The /billard-fo subdirectory shouldn't be an issue since the site was already running in this directory. Subdirectories cause headache if existing gpEasy websites are moved into or out of subdirectories, so don't try to fix this issue by moving the site out of /billard-fo!

Edited: 5 years ago#7919

hoghoj1
179 Posts
HH-Support

Hi Juergen,

the menus work fine now :-)

Excellent help from your side as always. Very handy, as I am definitely no programmer and have very little knowledge to php and css.

But I have made numerous nice websites with this little and very EASY to use pearl of CMS, as gpEasy is.

I had thought of moving the site out of the subdir, but waited for an answer to the error, so I wouldn't mess it up more.

But for future websites I will then have to rename settings.php and alter template.php with the addon lines.

Do you BTW know how many and maybe also the names of Themes, this would affect?

Kind regards
hoghoj1

5 years ago#7920

juergen
1.4K Posts
53.1K Downloads
16 Plugins
design, web development & visual effects

Hi hoghoj1

glad to hear that it works now!

A recommendation for handling errors like this one (dropotron): In Firefox install either the "Web Developer" Addon or "Firebug" (or both) which will provide you with valuable information especially about JavaScript errors. You can also use the bulit-in Developer Tools which are very good as well but the Web Deveolper Toolbar Addon has nice indicator icons for errors, which I do apprecciate.

For settings.php. Don't remove/rename it generally!
Mostly settings.php is used to define Extra Content Areas, wich will not render anymore if you remove/rename the file.

In your case and with the Extreme Surfing theme, settings.php only loads the dropotron JavaScript version 1.0 wich
A) does not work anymore with jQuery 1.11 included by gpEasy 4.4+ and
B) settings.php here does not make the $page variable/object global. I don't know how it ever worked this way - apparently some things changed in gpEasy recently.
If $page is used inside a PHP function or codeblock, it needs to be made global first using global $page; (same applies to oher variables like $dirPrefix, $addonRelativeCode, etc.)
C) maybe you even created a syntax error by editing settings.php. PHP syntax errors (like missing semicolons, brackets or quotes) are crucial because they are mostly fatal and gpEasy will try to "quarantine" the script to protect itself. (That's the "Warning: A component of this page has been disabled…")

I don't know which themes will be affected but if it's dropotron causing the error, we already know the fix. Watch out for this particular script in themes before updating gpEasy, especially in cases where you use themes from Dominion IT unless he updates to the current dropotron version. I'm uncertain if he uses dropotron in other themes but Extreme Surfing.
There will likely be even more themes/addons wich need to be updated to work with jQuery 1.11 (some of mine were also affected, like Nivo Slider). 
Web Developer tools will at least give you a clue if it happens. It will either show an error in the theme's/addon's javasript or in jQuery.js. Both will most likely indicate an incompatibility.
 

 

5 years ago#7921

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Luzern (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Website * ...

Find out more about our Provider Spotlight

Log In

  Register