Topic Closed
80 Posts


in OnePageToolkit (1.0b1) when selecting in the gadget-settings "none" for "show arrows" the first/last arrows still appear. Is that the way it is meant to be?

Thanks CS

4 years ago#9557

1.5K Posts
16 Plugins
design, web development & visual effects

Is that the way it is meant to be?

No, it isn't - here is the fix:

In Admin_OnePageToolkit.php from line 685, just add the grren marked lines:

    if( $gc['show_arrows'] == 'none' ){
    $css .= '
ul.OPTK-scrollIndicators li.OPTK-scrollFirst,
ul.OPTK-scrollIndicators li.OPTK-scrollFirst + br,
ul.OPTK-scrollIndicators li.OPTK-scrollLast,
ul.OPTK-scrollIndicators li.OPTK-scrollLast + br,
ul.OPTK-scrollIndicators li.OPTK-scrollPrev,
ul.OPTK-scrollIndicators li.OPTK-scrollPrev + br,
ul.OPTK-scrollIndicators li.OPTK-scrollNext,
ul.OPTK-scrollIndicators li.OPTK-scrollNext + br {

Save and afterwards go to the Admin page and save the options again (which will rewrite the Gadget's CSS).

Thanks for the heads up!


edit: I just changed it on my addons page (but didn't make a new version).
So you could re-download 1.0b1 and overwrite Admin_OnePageToolkit.php in you current installation.

Edited: 4 years ago#9560

80 Posts

Hi Jürgen,

works great, thanks for the fix!

4 years ago#9561

Topic Closed



elFinder 2.1.50 in Upcoming Release

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News


Company located in Tórshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In