Topic Closed
midrik
19 Posts

I get the following error when installing GPEasy:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

I have installed GPEasy without problems before on the same server. Ideas anyone? Thanks, -midrik

Edited: 10 years ago#891

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

This may be nearly anything. The question is, did you get the correct gpEasy installation screen and information?

please see my gpEasy Tutorials for information on installing gpEasy and what you should see and expect. Also, there are tutorials for setting up gpEasy locally with xampp lite and then just synchronizing gpEasy with your server--works the best for me.

If you can't resolve your issue with those tutorials then please let us know and try to get form information--e.g. what steps of installation were completed and what info did you get or not get.

Edited: 10 years ago#892

midrik
19 Posts

Thanks for your reply.

It is very weird, I have been able to install gpeasy without problems and using it. But today I tried a fresh install on a clean new domain account on the same server and I got the same error before the installation screen,.. did not get to the installation screen.

10 years ago#895

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

My guess is something changed with your host provider. Since gpEasy is pretty much self contained as long as you have correct file permissions and correct php version then it ought to work. If you were able to install it easily before and now you can't then ask your host what changed. . . Make sure you test the older version of gpEasy as well as the newer.

Host do change things. . .

10 years ago#896

midrik
19 Posts

Its my own server so I know if there are any changes made to it. But good point regarding the versions. If I remember correctly then I was using the version before this one when everything worked so well.

Going to try that version again and see how it goes.

10 years ago#897

midrik
19 Posts

Hi,

I have studied the error and it seems to always happen when I try to login for the first time after installing.

And remember I have one installation of gpeasy running on my server without any problems at all.

Any ideas?

10 years ago#905

Josh S.
2K Posts
283K Downloads
16 Themes
18 Plugins

Hmm,

And remember I have one installation of gpeasy running on my server without any problems at all.

Which version of gpEasy is running this installation? And what's the latest version you've seen the Internal Server Error with?

Also, is there an .htaccess file in the root folder of the installation you're having a problem with? If there is and you remove it, does the problem go away?

Edited: 10 years ago#925

midrik
19 Posts

Hi,

Actually there was a .htaccess file that I removed and after that all is working well... it seems :)

Should I have .htaccess file or should I just skip it?

10 years ago#934

Josh S.
2K Posts
283K Downloads
16 Themes
18 Plugins

The .htaccess file isn't required, and actually isn't there by default. Are you using the latest release (currently 1.7b2)?

Could you post the contents of your htaccess file here or email them to me so that I can try to figure out what's going on?

Edited: 10 years ago#935

midrik
19 Posts

Hi and thanks for your help.

I was using the b1 version but now I tested the 1.7.2 b2 and I can´t even get to the installation screen. So I think my theory with .htaccess file was not correct.

I uploaded also to another test domain on same server and then checked the Cpanel error log which had the following:

[Mon Oct 11 16:39:24 2010] [error] [client 194.144.29.160] SoftException in Application.cpp:264: File "/home/einka/public_html/gptest/gpEasy/index.php" is writeable by others, referer: http://einka.info/gptest/

Any ideas?

Edited: 10 years ago#977

midrik
19 Posts

I think I have solved this.

After extracting the gpeasy zip the files are all with permission 777, it seems to put my server in some panic mode. As soon as I chmod all folders to 755 and all files to 644 then I can install and all is well.

I will let you know if I the problem shows up again.

Thanks :)

10 years ago#978

mavoe
1 Posts

Oh great - now it works. I just tried to arrive http://einka.info/gptest/gpEasy/   Looks good. Now you can start with design :-)

Edited: 10 years ago#980

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in Tórshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register