Topic Closed
fl
2 Posts

Hello everybody, and thank you for making Typesetter possible!
Does anybody before facing the issue shown on the picture?
Every permissions on every folder are available and the apache root user is used.
We've tried anything to get the folder writable and also tried step by step the way explained in this article: http://idroot.net/linux/install-typesetter-cms-centos-7/

Maybe someone can help me out, to get Typesetter successfully installed.

Thank you very much!

If we find a solution i will report it here.

Greetings,
Felix

3 years ago#10512

martin
34 Posts
605 Downloads
1 Themes
Looks curious. How did you install Typesetter? Have you also tried to unzip the package on your computer and upload it via FTP?
3 years ago#10523

juergen
1.5K Posts
57.9K Downloads
16 Plugins
design, web development & visual effects

A bit late of a reply.

I myself experienced CentOS/RedHat to be tricky when it comes to file permissions, mostly because of restrictive selinux policies.
If I remember correctly, Apache/PHP needs write permissions not only to the server root and /data dir but all the way down the directory tree* in order to gain write access. I believe I solved this once with some uncommon group permissions.
(*I also recall some fiddling to make permissions work for symbolic links.)

There are some tutorials about installing Typesetter on CentOS you will find googling typesetter centos.
HTH

3 years ago#10531

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register