Topic Closed
christian
2 Posts

Hi folks!

 

I gave Typesetter CMS a try ... but it started not so great:

 

After successfully installing Typesetter (installation page checked everything green) I entered the default home page and was greeted with the following:

 

 

Seems as if something went wrong with the SCSS compiling to CSS. Can some one explain? I "did nothing wrong", just what I was told on the documentation page on how to install Typesetter.

Note: I installed it in a subdirectory (/typesetter/). 

 

Hoping for help!

Thanks
Christian

 

 

11 months ago#11690

juergen
1.5K Posts
57.9K Downloads
16 Plugins
design, web development & visual effects

Seems as if something went wrong with the SCSS compiling to CSS.

Definitely. From the error messages it appears that Typesetter fails to import the Bootstrap 3 SCSS sources from /typesetter/include/thirdparty/Bootstrap3/scss
Both the missing mixin and the variable are defined there.

Since you don't get other errors like memory exhaustion, I would assume that these files are actually missing. Please check the abovementioned folder on your server and compare it with the one from the installation ZIP. If there are files missing or file sizes don't match, maybe sth. went wrong with the file transfer (FTP, SFTP, whatever you used). In such cases other files may also be missing.

Unlikely but possible: sometimes extracting the installer ZIP archive to a local Disk or LAN subdirectory with an already extremely long path may exceed the max local path length of the OS (=~ 256 characters NTFS, Ext3 and Ext4). However, you should have been notified then. This happens to me from time to time when archiving projects on my NAS

If all files are ok on your server, we'll have to check other possible causes.

BTW: There is also Typesetter 5.2 RC1 (release candidate) on GitHub (Download the master ZIP) You might want to check it out. 5.2 Will be released in the near future.

 

 

Edited: 11 months ago#11691

christian
2 Posts

Alright, you put me on the right track, I found out what was going wrong:

I used WinSCP to upload the unzipped content. In WinSCP for my normal workflow I have a file transfer profile that omits everything with "scss" and "sass" and does not upload it. So the SCSS files never reached the server in the first place. *facepalm*

I now unzipped the archive directly on the server and everything works as it should.

So my bad, sorry for disturbing. ;)
Looking forward to explore Typesetter CMS!

 

Thanks 
Christian

11 months ago#11692

juergen
1.5K Posts
57.9K Downloads
16 Plugins
design, web development & visual effects

… and everything works as it should.
So my bad, sorry for disturbing. ;)

You're welcome. Glad to hear it works now.
It would have been disturbing to me if the files were actually there ;)

11 months ago#11693

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register