Topic Closed

hello, vTip_  plugins do not work on the latest version 2.0b2

11 years ago#1459

Josh S.
2K Posts
304K Downloads
16 Themes
18 Plugins

Just checked them and found that there were some changes to gpEasy (and a bug I just found) that affect the vTip plugins. I've fixed the bug and we'll work on getting the plugins updated to work with the most recent package.

11 years ago#1461

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

Sorry about the delay. I haven't been able to get to things the past few days. I hope to get to the plugins today. Thanks to Josh it shouldn't be a problem getting them all straightened out. Thanks for your help Josh, and again sorry about the delay.

11 years ago#1487

Tobias
40 Posts

Temporary dirty hack for vTip Plugins which worked for me as a workaround: Find the vtip.js in one of the /data/_addoncode/.../ directories and manually update the path to the style sheet and vtip_arrow.png

Bests, Tobias  

11 years ago#1503

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

They all should be working fine with gpEasy 2.0. Please download the updated version and let me know if there are any problems. Thanks and sorry about the delay.

11 years ago#1511

Excuse me, but the last updated don't work with gpeasy v 2.0b2

11 years ago#1514

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

I just downloaded and tested vTip_Black 2.1 on my local install and it worked fine.

Did you add the gadget to a layout? The gadget does not work on admin pages--helps to prevent conflicts.

If still not working please give me some details as to your configuration--e.g. subdirectory or not, theme, etc.

11 years ago#1515

Hello,

thank you for your work but the plugin don't work.

I downloaded and tested vTip_Black 2.1 and 2.1 vTip_White

http://bibliobox.free.fr

ID >> admin

pass >> demo

the plugin don't work on my local install also

 

Edited: 11 years ago#1527

Tobias
40 Posts

Hm odd... Yesterday i updated the vTip_Black plugin and it worked... Today it doesn't. Guess it had some old stuff in the  _cache. So yes it looks like something is missing / wrong The stylesheet include looks like a server path, not relative to html root:

href="/data//home/xxx/public_html/data/_addoncode/me0nipk/style.css"

Should be just /data/_addoncode imho... Bests, Tobias  

11 years ago#1530

Tobias
40 Posts

Yes that seems to be it.. Using href="{$addonRelativeCode}/style.css" in AddOn.ini has a problem - at least on 2.0b2.

 

11 years ago#1531

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

yep, that's the problem. I have to upload a version of 2.0b2 to test it with. That code works fine on a localhost install but apparently not on the server.

Will update when fixed.

 

11 years ago#1532

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

OK, I think it should be working fine now. Tested it on a subdirectory uploaded to my server.

The problem, as Tobias discovered also, is the $addonRelativeCode in the ini file--that code works fine in the php file for the JS but for some reason isn't working properly in the ini file. . . . so

;html_head = '<link rel="stylesheet" href="{$addonRelativeCode}/style.css" type="text/css" />';  --seems to be a bug - does not give correct path from root

 

Changed to:
html_head = '<link rel="stylesheet" href="../data/_addoncode/{$addon}/style.css" type="text/css" />';
 
Please upgrade to 2.2 version and let me know if there is any problems. 
 
thanks for everyones help!!!
 
11 years ago#1533

I downloaded and tested 2.2 vTip_White but the plugin don't work.

http://bibliobox.free.fr

ID >> admin

pass >> demo

the plugin v 2.2 don't work on my local install also

11 years ago#1535

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

your site is spitting out

<link rel="stylesheet" href="../data/_addoncode/{$addon}/style.css" type="text/css" />

as the link. as you can see it didn't convert $addon to the proper folder.

I'm not sure why yours is doing that. It may be yet another bug. I know the 2.0b2 version I have has a couple fixes .

You can upload the version of gpEasy I have and test it.

https://docs.google.com/leaf?id=0B6YPHs_S2rFrMGZiMjhlMTgtMmEzOS00ZjNhLTg2YjMtMTY3OTYzNzQ3Njkw&hl=en

there seems to be a few bugs in 2.0b2. I haven't had time to play with it much and I'm not running it on my server because there is a lot on my site that needs to be changed over. Please upload the include from the gpEasy I've uploaded and see how that goes.

 

11 years ago#1536

if I install on a server gpeasy http://gpeasy.00000web.info it works well. But do you have a solution for this to work on an installation that has been made. (example bibliobox.free.fr) If not I am forced to start over. Thank you.

11 years ago#1538

Tobias
40 Posts

Hi Strodbeck.

Same problem on my gpEasy installation: <link rel="stylesheet" href="../data/_addoncode/{$addon}/style.css" type="text/css" />

Guess there must be some fix in your version, which the official download link does not have yet. Maybe worth pulling a snapshot from SVN and making a Diff. @[email protected]: Just hardcode the link to the stylesheet until a fix is available...

Bests, Tobias

 

11 years ago#1539

Tobias
40 Posts

Beyond Compare is your friend. The only difference between your version and the official version is in admin_addon_install.php Line 280-284:

Downloaded version:         $variables = array(                        /* '{$addon}'=>$this->install_folder_name, */                     '{$addonRelativeData}'=> common::GetDir('/data/_addondata/'.$this->data_folder),                     '{$addonRelativeCode}'=> common::GetDir('/data/'.$this->addon_folder.'/'.$this->install_folder_name),                     );  

Your version:

        $variables = array(                         '{$addon}'=>$this->install_folder_name,                     '{$addonRelativeData}'=> common::GetDir('/data/_addondata/'.$this->data_folder),                     '{$addonRelativeCode}'=> common::GetDir('/data/'.$this->addon_folder_name.'/'.$this->install_folder_name),                     );

 

Bests, Tobias

11 years ago#1541

Josh S.
2K Posts
304K Downloads
16 Themes
18 Plugins

Sorry for the trouble everyone, the {$addonRelativeCode} variable was set incorrectly in 2.0b2. It has been fixed as Tobias has shown in the version comaparison and I'll have the updated code out in a new package next week. Again, sorry for the trouble.

11 years ago#1545

Charles S
448 Posts
13.7K Downloads
2 Themes
8 Plugins

best work around. . . for those who want to use the beta before it is ready. Please note that I reverted the plugin back to 2.1 as that is the better code.

Edit the ini file of the plugin.

remove:

html_head = '<link rel="stylesheet" href="{$addonRelativeCode}/style.css" type="text/css" />';

add:

html_head = '<link rel="stylesheet" href="/addons/vTip_White/style.css" type="text/css" />';

make sure to change "vTip_White" to the appropriate plugin folder name (vTip_Red, vTip_Blue, etc)

 

Make sure you don't delete the plugin form the addons folder after you install--as you can see you will be calling the css directly form that folder.

OR

Do as Tobias suggest and replace the proper code listed above in his post.

Edited: 11 years ago#1546

Tobias
40 Posts

Great! Problem solved! The plugins from strodbeck works fine when installing them on a gpEasy version that has the changes in the admin_addon_install.php as shown above in blue.

Thanks, Tobias

 

11 years ago#1548

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Ennetb├╝rgen (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Websi...

Find out more about our Provider Spotlight

Log In

  Register