Topic Closed

Sir

Thanks in advance.

I followed all instructions to install GPEasy.But while installation,the checkings of the server is all correct and passed.

But i get a error message "could not save pages.php" and the installation stops.

Please help,as i have to put up this gpeasy for my client this week. GP easy is really easy.

SKSundaram,INDIA

10 years ago#2467

Josh S.
2K Posts
296K Downloads
16 Themes
18 Plugins

Hi,

I couldn't tell you exactly what is happening, but it appears there's something about your server that is incompatible with gpEasy. The message that pages.php couldn't be saved is a result of gpEasy's inability to use the fopen() and/or fwrite() functions in php.

If you'd like to dig further, you could turn debugging on then go through the installation again. If you do decide to dig deeper, I'd be happy to help you out and try to get to the bottom of the problem.

Sorry for the trouble

 

10 years ago#2468

CCacer
2 Posts

I'm getting the same problem as this. Safe mode is off, it found PHP 5.2.6  and everything says "passed".

I've changed that debugging setting mentioned above, and it is a permissions error. Unfortunately, I'm not sure what I need to change here as it is a Windows/IIS server so I'm not sure the chmod stuff applies? It is a shared hosting account using Plesk.

It's a shame because this does look like a great CMS.

Edited: 10 years ago#2549

CCacer
2 Posts

Ah, ok, I got around that by messing about with the permissions on the data folder. It is very confusing on Plesk compared to a normal Linux system!

I am still getting 4 warnings related to fopen (looks like it is trying to open an htaccess file), chmod, and ulink functions called in install_tools.php and remoteget.php, but I think this is a windows/iis/plesk issue and my lack of expertise rather than a GPEasy issue.

I don't think I'll be able to get this working in any secure way, so I'll just revist if I move back to Linux/Apache in future.

Does look cool though, so good work!

10 years ago#2550

I have the same problem. While installation the checking of the server is passed, but I get the message "Could not save pages.php". The screenshot is here. It's not isolated case, and if everything is passed, so maybe is it bug of the CMS, isn't it? If it's a server problem, the server checking could not be passed... 

I've tried to turn debugging on, but there's not such line //define('gpdebug',true); in the index.php file. I've added the line, but it didn't help.

Any suggestion, that's the problem?

Edited: 9 years ago#3097

Josh S.
2K Posts
296K Downloads
16 Themes
18 Plugins

Though not exactly the same, this does sound like a bug that was worked on and fixed recently: bug report

Are you on a Windows machine or Linux/Unix?

so maybe is it bug of the CMS, isn't it? If it's a server problem, the server checking could not be passed...

That's what I would think too.

gpEasy uses php's is_writable() function to determine if the /data directory is writable. If that returns true, then the check passes and gpEasy is allowed to attempt to write to the directory using php's fopen() and fwrite() functions. If those fail to write files to the /data directory, then the installation stops (as you're seeing).

The reason I ask if you're using a Windows machine is that php does not always return accurately for the is_writable() function. We're attempting to address this problem in php with the fix in the above bug report.

9 years ago#3098

It was Linux server. Now I change it to another Linux hosting and install was successful. There's something strange. :-|

But now there's another problem. I can't log in. Every link is with "index.php" part in it. For example, link for log in is "mysite.com/index.php/Admin_Main".

If I'm trying to open such link, I get blank page with inscription "No input file specified". I remove this part manually and the link works, I see login form. But when I click login button, I get another page with "index.php" part in link and blank page.

So I can't log in and use my website.

9 years ago#3115

Josh S.
2K Posts
296K Downloads
16 Themes
18 Plugins

Your server probably doesn't support mod_env so gpEasy doesn't see that you have the .htaccess code to get rid of index.php. You can tell gpEasy to use links without index.php by modifying your configuration file: docs.gpeasy.com/index.php. See the section describing define('gp_indexphp',false);

Edited: 9 years ago#3120

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register