Topic Closed

I unzipped the file, moved the contents to a Virtual Directory on Win XP SP2, IIS 5.1, refreshed IIS and accessed the index.php page.

All went well until I clicked the "Install" tab/button at which time I get a page indicating that "The page cannot be found"

Was hoping to have better luck.

 

10 years ago#2491

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

I would hope for better results than that too. We can look at a couple of things if you like.

The first thing is I'd check to make sure the url in your browser's location bar isn't pointing to the wrong location. If when you open up the installer the url is http://localhost/install_folder/ then, when you click the install button, it should change to http://localhost/install_folder/index.php/

The next thing is to check that second url by just typing it into your location bar and one variation of it. I'd check http://localhost/install_folder/index.php/ and http://localhost/install_folder/index.php (note missing trailing slash) to see if you get the "page cannot be found" error with either of them.

 

10 years ago#2496

I would hope for better results than that too. We can look at a couple of things if you like.

The first thing is I'd check to make sure the url in your browser's location bar isn't pointing to the wrong location. If when you open up the installer the url is http://localhost/install_folder/ then, when you click the install button, it should change to http://localhost/install_folder/index.php/     this did change as indicated

The next thing is to check that second url by just typing it into your location bar and one variation of it. I'd check http://localhost/install_folder/index.php/ and http://localhost/install_folder/index.php (note missing trailing slash) to see if you get the "page cannot be found" error with either of them.   did get error with http://localhost/install_folder/index.php but not http://localhost/install_folder/index.php

 

 

10 years ago#2497

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Looks like there's a possibility we can fix this... I believe you'll need to change the cgi.fix_pathinfo setting in php. This can be done in your php.ini file. Try this setting:

cgi.fix_pathinfo = 1

When editing your php.ini file, it's a good idea to edit the existing entry rather than just adding a new entry at the bottom of the page. After this setting is changed, restart IIS and see if it works.

If you don't have access to your php.ini file, it might be possible to change it in a different location.

Sorry for the trouble

10 years ago#2498

The cgi.fix_pathinfo  info statement was already there and set to 1.

 

10 years ago#2499

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Everything I've found references setting it to 1, but I guess it wouldn't hurt to try 0.

Also, (I appologize if this is way below your experience level) make sure the line in your php.ini file isn't commented. i.e. There shouldn't be a semicolon at the beginning of it.

10 years ago#2500

Tried it at 0 and still gets page not found.

Put it back to 1

About my level of experience - this is new to me...

What next?

10 years ago#2501

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Just doing google searches now to see if there's any relevant information:

10 years ago#2502

The last statement in the IIS log follows:

23:24:08 127.0.0.1 POST /gpEasy-Forum/index.php 400

The last entries in the PHP log follows:

fl=D:\gpEasy_2.2\include\install\install.php
fn=require_once::D:\gpEasy_2.2\include\install\install.php
1 333
cfn=php::defined
calls=1 0 0
2 1
cfn=includeFile
calls=1 0 0
7 1808
cfn=includeFile
calls=1 0 0
8 2455
cfn=includeFile
calls=1 0 0
9 1400
cfn=gp_install->gp_install
calls=1 0 0
194 9074

fl=D:\gpEasy_2.2\include\common.php
fn=includeFile
1042 2701
cfn=require_once::D:\gpEasy_2.2\include\install\install.php
calls=1 0 0
259 15074

What next?

 

10 years ago#2503

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

So the 400 error (as shown in your IIS log) indicates that the server "Cannot resolve the request" which isn't much of a surprise. I was hoping for something a little different, because the 400 error brings me back to thinking about the cgi.fix_pathinfo setting.

There's another setting we might check, cgi.force_redirect, though I don't think it's the problem.

cgi.force_redirect = 0

We should probably also verify that the settings are making it to php. Create a phpinfo.php file in your root directory with the following contents:

<?php

phpinfo();

Then open your phpinfo.php file in your browser and look for the fix_pathinfo and force_redirect settings and verify that their values are correct.

10 years ago#2507

cgi_fix_pathinfo = 1

cgi_force_recirect = 0

note that phpinfo indicates that virtual directory support is disabled and this site is configured as a Virtual Directory in IIS.

 

10 years ago#2508

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

I just found an article that talks about the specific problem we're having and how to fix it. Take a look at the "Configure Script Mapping" section.

http://911-need-code-help.blogspot.com/2011/02/url-rewriting-on-iis-using-pathinfo.html

10 years ago#2509

I un-chedked the "Check that file exists" option as suggested by the article you found and the installation script completed and I am now able to login into the Administration pages.

Many thanks.

10 years ago#2510

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Fabulous, glad it's working!

10 years ago#2511

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register