Topic Closed

Hi, when trying to install the multiple-site plugin, I get the error
"Cannot install this addon. This is not the root installation of gpEasy."
Well: it is the root installation!
What does it check for? gpEasy is installed in a subsubsubsub... folder, partly because it is a development environment.
But that could'nt be the reason? could it? Any ideas?
your's
felixhelix

11 years ago#2661

Josh S.
2K Posts
306K Downloads
16 Themes
18 Plugins

Hmm, the sub-folder thing shouldn't be a problem...

You can override the check by modifying the Install_Check.php file in the addon folder. You can find the Install_Check.php file here: /your/install/folder/addons/Multi Site

Then modify the text of the file so it doesn't compare the $rootDir and $dataDir paths.

if( $dataDir !== $rootDir ){
  echo '<p style="color:red">Cannot install this addon. This is not the root installation of gpEasy.</p>';
  $passed = false;
}

You could simply change "$passed = false" to "$passed = true" here.

11 years ago#2662

Thanks for you'r quick response :-)
I commented this section out, and could install the plugin.
But when I try to configure the plugin (Plugin / Multiple Site / Setup Site) it again tells me this ugly thing :
"Notice: This is not the root installation of gpEasy."
:-(
And I cannot do anything at all.

Any more ideas?

your's
felixhelix

11 years ago#2663

Josh S.
2K Posts
306K Downloads
16 Themes
18 Plugins

Ok, that one is on line 44 of the SetupSite.php file in the same directory.

This is clearly a problem with the multi-site script. I'll try to have a fix for the next release.

Update: just checked and that should be the only other root-install check. Also, just found a better way to check so this won't be a problem in future releases.

Edited: 11 years ago#2664

Juri-S
9 Posts
20.1K Downloads
1 Themes

Hi Josh S.
I have pretty much the same problem when installing the multiple-site addons.

"Can not install this addon. This is not the root installation of gpEasy."

Now I wanted to ask whether you have already found a solution.

11 years ago#3024

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

creisi productions

Dienstleistungen von creisi productions, Ennetb├╝rgen (Schweiz): * Konzeption, Planung und Erstellung Ihres Internet-Auftritts * Betreuung und Aktualisierung/Pflege Ihrer Websi...

Find out more about our Provider Spotlight

Log In

  Register