Topic Closed

Hello, curretnly I am stuck on version 1.7b1.  When I tried to upgrade to 2.3.1 it apeared to finish and then on reloading my page I got a simple line of text with no formating or other html: Please upgrade to version 1.8 before upgrading to this version.

I then wiped the directory and put my original fils back using a backup.  The site came back up just fine minus one page I was editing right before the upgrade.  I simply recreated it using GPeasys file manager.

However I no longer can use the add image or link buttons (or any other advanced features of the page editor.)  Typing text and changing bold and simialr work just fine.  When you click on the image or link buttons the page hangs at "transfering data from www.cwalv.com"

 

I tried a manual upgrade as well, went back to the Please upgrade message.  I also did a search for that text in the files and can not find that message in the code.

 

 

9 years ago#2713

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

However I no longer can use the add image or link buttons (or any other advanced features of the page editor.)  Typing text and changing bold and simialr work just fine.  When you click on the image or link buttons the page hangs at "transfering data from www.cwalv.com"

The "transfering data.." message could be a message your browser displays when it's attempting to load content from the web. Those buttons are part of ckeditor and don't require much to load other than downloading a javascript file from the server though, so I'm suprised it's hanging up. The only time it hasn't worked for me is when I have a bad internet connection. I'd say it's possible something on the server is preventing js files from downloading, but if you've already loaded the editor, then it's definitely not the case. You might check to make sure the folder containing ckeditor was fully uploaded (/include/thirdparty/ckeditor_34).

curretnly I am stuck on version 1.7b1.  When I tried to upgrade to 2.3.1 it apeared to finish and then on reloading my page I got a simple line of text with no formating or other html: Please upgrade to version 1.8 before upgrading to this version.

The integrated upgrade tool won't work correctly (as you've found) since 1.7 is an older release. You can download an earlier release and do a manual upgrade though. 

Sorry for the trouble, let me know how things go,

-Josh

9 years ago#2714

Thank you for the help.

I tried the manual upgrade and it just leaves me with the "Please upgrade to version 1.8 before upgrading to this version" error.

I had some sucsess using sed to replace all mentions of the old version to the new version in the data folder.  That worked and I can load my site but all my formating and theme mods went away, still working on that.

I guess I also broke the login and lost pasword functions.

 

Edited: 9 years ago#2716

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

I tried the manual upgrade and it just leaves me with the "Please upgrade to version 1.8 before upgrading to this version" error.

Are you sure you uploaded a version of gpEasy less than 2.3? Version 2.0 should work and nowhere in the code of 2.0 does "Please upgrade to version 1.8.." exist. 

I had some sucsess using sed to replace all mentions of the old version to the new version in the data folder. 

Be very careful with that. The upgrade process from 1.7 looks at the version of data file to see if it needs to be updated or not. If you do it manually, gpEasy won't be able to update your data correctly.

9 years ago#2717

I only tried 2.3.1, I could not find a down load for any thing less.

 

9 years ago#2718

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Sorry, I should have been clearer earlier. I linked to one in my first post in the text "download an earlier release".

9 years ago#2719

oops, your right. I missed the link.  I did it on a test copy and it worked with some errors related to themes (I only changed includes)  and my website came up looking nice.

9 years ago#2720

Josh S.
2K Posts
295K Downloads
16 Themes
18 Plugins

Sounds better. Let me know if anything else weird happens.

-Josh

9 years ago#2721

Topic Closed

 

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register