Posts by: andrew

Posts: 14
Post: 7009
Topic: Not explicitly adding home/start page to menu?

So, from what I can tell, the "start" page is the first menu item.  Since clicking the logo also brings one to the start page, I don't want to explicitly have in the menu "home" as an option.  The best I can do right now is leave the label blank, but that still leaves an annoying highlighted square on the blank menu label when the visitor is on the home page.

www.proedu.sk/

 

9 years ago
Post: 6988
Topic: Editing in nginx problem solved
I've got the permissions also set right.  I think the error I had may have come from some permission changes during an upgrade to nginx.

I like your script.  Everytime I've copied-pasted-edited nginx config files, manually set up mysql (usually for drupal up to now), I've thought how I ought to have some script to do it...
9 years ago
Post: 6987
Topic: Adding a PNG logo to a Bootswatch theme

The bootswatch themes meet all of my needs except for one-- using a graphic logo at the top left hand of the navbar, albeit a small one.  I guess maybe the reason it isn't done is the mobile first nature of the theme, which I understand, but its a really tiny PNG of an olive branch...

So if I have a bootswatch theme set up as I want otherwise, where should I "hack" around to get a PNG up there?

9 years ago
Post: 6982
Topic: Editing in nginx problem solved
Hi,

I followed the various information to set up gpeasy with nginx (though this was for version 3 gpeasy) linked elsewhere in these forums.  I tried inserting "

define('gp_indexphp',false);"

as well into gpconfig.php though I don't know if that works anymore.

Anyway, I could access and change most config settings, but I could not edit pages.  When I click edit with debug turned on I get this:

thrownError = SyntaxError: missing ) in parenthetical

with debug off:

There was an error processing the last request. Please reload this page to continue.

If you look in your nginx log and see something like:
open() "//var/lib/nginx/tmp/fastcgi/1/01/0000000011" failed (13: Permission denied) while reading upstream

your problem is coming from permissions being wrong on /var/lib/nginx which need to be set to the user and group nginx runs under.

I don't know if anyone else will have this problem, but if editing is not working, dig deeper into nginx logs and see if this isn't at the root.

9 years ago

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

Log In

  Register