Posts by: barry

Posts: 9
Post: 11333
Topic: Special Contact Form error

Ok, figured out part of the problem. Mail host recently enforced the From Address matches the SMTPAuth Username. However, unchecking From Handling seems to make no difference when using the Special Contact Form. To test my theory, I filled the form using the email address of the SMTPAuth Username, and bingo, the form works. I'm looking for a way to create a hidden field within Special Contact Form in which to set the SMTPAuth Username value. It doesn't matter if the value can be discovered, as all mail to that address is automatically deleted.Any suggestion on how to achieve that?

 

2 years ago
Post: 11329
Topic: Debug Info: .. addon data could not be fetched

I can confirm the same problem on php 5.5:

 

Debug Info

Error Message: Sorry, the addon data could not be fetched.


Backtrace

File /include/admin/Addon/Install.php

Line 363

Class gp\admin\Addon\Install

Function ParseResponse


Details

Redir 0

FailedMethods stream,

NotSupported

stream no handle

lang_key Sorry, data not fetched


Your Environment

PHP Version 5.5.18

CMS Version 5.1

index.php Rewrite True

Server Software Apache

2 years ago
Post: 11324
Topic: Special Contact Form error

I have installed Special Contact Form 3.0.2 on two separate websites, but they both exhibit the same problem. They display correctly, but when clicking on the Send button, the following message appears at the top of the form:

Sorry

We encountered an error, when sending your message ☹

This occurs when using the default Special Contact Form, even after disabling anti-Spam protection. The web page on which the form is displayed is using the Bootswatch Scss/Flatly template.

Email settings are correct (SMTPAuth) as the default Typesetter Contact form works correctly.

Any suggestion on how to solve this issue would be appreciated.

2 years ago
Post: 11323
Topic: Cannot search/install plugins from Typesetter

In the back end, Plugins > Download Plugins fails with the message

Sorry, the addon data could not be fetched from TypesetterCMS.com. More Info...

View search results on TypesetterCMS.com

Clicking the more info link brings up a Debug Info page on http://www.typesettercms.com. Is something broken?

2 years ago
Post: 10568
Topic: Default installation displays blank pages
My hosting provider has kindly increased memory_limit to a whopping 512M, and problem has been solved.
3 years ago
Post: 10566
Topic: Default installation displays blank pages

phpinfo reports memory_limit of 24M

There's nothing in the error log except:

[Tue Jan 23 15:51:44 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/default_html, referer: http://domain.com/about
[Tue Jan 23 15:52:13 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/About
[Tue Jan 23 15:52:21 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/About
[Tue Jan 23 15:52:47 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/contact
[Tue Jan 23 21:26:26 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/data/_cache/jquery.min.map;
[Tue Jan 23 21:26:41 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/data/_cache/jquery.min.map;
[Tue Jan 23 21:27:14 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/data/_cache/jquery.min.map;
[Wed Jan 24 00:49:31 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/data/_cache/jquery.min.map;
[Wed Jan 24 01:07:48 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/More, referer: http://domain.com/
[Wed Jan 24 01:07:48 2018] [error] [client 123.123.123.123] File does not exist: /hsphere/path/to/domain.com/default_html
I've enabled Report Errors in the Administration Panel but that shows nothing. I guess next step is to enable gpdebug and gpdebugjs in gpconfig.php?
3 years ago
Post: 10563
Topic: Default installation displays blank pages

It might be a memory consumption issue. I experimented with include/thirdparty/Bootstrap3/scss/_bootstrap.scss commenting out various combinations of @import. For example commenting out all Components w/ JavaScript allows the page to load correctly. I've checked that it's not these components specifically, by uncommenting the lines one by one and commenting out other @imports. It seems the be a matter of too many imports, rather than any specific one.

I'm not sure how I can test this theory. Any suggestions?

3 years ago
Post: 10562
Topic: Default installation displays blank pages

According to phpinfo, host is x86_64-redhat-linux-gnu.

Error log does not show anything, but Transfer Log does provide the following info:

When About page is accessed when not logged into admin panel (edited for privacy):

[23/Jan/2018:15:53:07 -0600] "GET / HTTP/1.1" 200 2898 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36 OPR/50.0.2762.45"

[23/Jan/2018:15:53:07 -0600] "GET /data/_cache/combined_5n8m63p2ziu62ulxhw9tw6.js HTTP/1.1" 200 133094 "http://domain.com/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36 OPR/50.0.2762.45"

[23/Jan/2018:15:53:13 -0600] "GET /index.php/About HTTP/1.1" 500 - "http://domain.com/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36 OPR/50.0.2762.45"

When logged in, editing a layout and selecting Bootswatch Flatly:

[23/Jan/2018:16:16:20 -0600] "GET /index.php/Admin_Theme_Content/Edit/900masg HTTP/1.1" 200 2136 "http://domain.com/index.php/Admin_Theme_Content/Edit/default?redir=Home" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0"

[23/Jan/2018:16:16:20 -0600] "GET /index.php/Admin_Theme_Content/Edit/900masg?cmd=in_iframe HTTP/1.1" 200 4721 "http://domain.com/index.php/Admin_Theme_Content/Edit/900masg" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0"

But when selecting a Bootswatch_Scss layout:

[23/Jan/2018:16:22:08 -0600] "GET /index.php/Admin_Theme_Content/Edit/default HTTP/1.1" 200 8453 "http://domain.com/index.php/Admin_Theme_Content/Edit/900masg" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0"

[23/Jan/2018:16:22:08 -0600] "GET /index.php/Admin_Theme_Content/Edit/default?cmd=in_iframe HTTP/1.1" 500 - "http://domain.com/index.php/Admin_Theme_Content/Edit/default" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0"

The network tab for Bootswatch Flatly:

and for Bootswatch_Scss:

3 years ago
Post: 10558
Topic: Default installation displays blank pages

Typesetter 5.1, php 5.5, Any browser. Installation goes fine, but after completing install, all the default pages are bank.  Log into index.php/Admin works, but trying to edit any of the default pages returns a blank browser screen. If I create a new layout from any of the Bootswatch Flatly themes, and apply it to a page, the page displays correctly. The same applies to creating a layout from the Three Point 5 theme. But any layout created from any Bootswatch Scss theme results in a blank page. Creating a layout from the new Cajón Scss theme in v 5.1 also results in a blank page. I've tried installing Typesetter versions 5.0.3 and 5.1 on several sites, always with the same results. I've also tried php versions 5.3, 5.4 as well as 5.5, and browsers including  Firefox, Chromium, & Opera. Same result.

If I preview a Bootswatch Scss or Cajón Scss theme or edit a Bootswatch Scss or Cajón Scss layout, the iframe in which the sample page is supposed to be displayed is blank in browser View Frame Source. When previewing/editing Bootswatch Flatly and Three Point 5 themes/layouts, browser View Frame Source shows the HTML code for the page as expected. 

Has anyone experienced this odd behaviour?

3 years ago

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in Tórshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register