Posts by: DVWG

Posts: 11
Post: 11276
Topic: Subdomain installation problem


I have a site running Typesetter, which I'm happy with.  Howeveer. our organisation are holding a festival, which I wish to create a second designated site for, in a subdomain,

My hosts provide me with ample space and when I log in via FTP, I get a list of folders, one of which is called "public_html" which is the root of my site, if you will.  Therefore this folder contains the usual subdirectories of a Typesetter install - data, themes, addon, include. 

When I set up a subdomain in cPanel,, a new folder named "whatever" appears in my public_html folder.  If I upload the Typesetter install files to this folder, then navigate to, the install form appears.  However, when I complete the form and click Install, it just reloads the blank install form.  No error message or anything given. Any ideas as to why this might be or how to determine what the reason for failure is?



2 years ago
Post: 11207
Topic: Migration problems

You're very good at this!

I added the lines to template.php, loaded the site, copied the output.  Then I logged into cPanel on my hosts and updated from PHP 5.6 to PHP 7.2 and refreshed the site

PHP 5.6
gd_info =
   [GD Version] => (string)bundled (2.1.0 compatible)
   [FreeType Support] => (boolean)true
   [FreeType Linkage] => (string)with freetype
   [T1Lib Support] => (boolean)true
   [GIF Read Support] => (boolean)true
   [GIF Create Support] => (boolean)true
   [JPEG Support] => (boolean)true
   [PNG Support] => (boolean)true
   [WBMP Support] => (boolean)true
   [XPM Support] => (boolean)true
   [XBM Support] => (boolean)true
   [WebP Support] => (boolean)true
   [JIS-mapped Japanese Font Support] => (boolean)false

PHP 7.2
gd_info =


I'll email my hosts and politely request implementation.



2 years ago
Post: 11205
Topic: Migration problems

Hello once again Juergen and thanks again for your help.

It seems that my new hosts' default php version is 7.2. Reverting to php-v5.6 corrects the problem with thumbnail generation.  I am fine with this for now but my hosts tell me that support for 5.x wil be dropped soon. ls the reason for this likely to be linked to typesetter, or to my hosts, as I shall need to address the matter in the medium term.



2 years ago
Post: 11203
Topic: Migration problems

OK, I thought I was out of the woods with this one.

The site now works fine on the new server.  Our only problem now is that when I upload a new image to a gallery, no thumbnail is created.  I copied all the old images and thumbnails across using FTP and they work fine but if I upload via the Typesetter gallery page, no thumbnails are generated.

All files have 666 permissions and folders 777 permissions.

Example gallery at

Any ideas why this might be, anyone?

2 years ago
Post: 11202
Topic: Site looks different with https!


Thanks again!

2 years ago
Post: 11200
Topic: Site looks different with https!


if you visit my typesetter site you can see how my site should look.  If you go to, the default font is different and it affects the geometry of the layour.  My hosting provider deny that this could possibly be anything to do with server configuration and say it's a CMS issue.  Has anyone any ideas why this may happen?



2 years ago
Post: 11193
Topic: Migration problems

Hi. Solved!

It was not the folders but the individual files therein which I found to have different permissions on the old and new sites.  Having batch corrected these, the site now works, login and all!

Thanks for all your help!



2 years ago
Post: 11189
Topic: Migration problems

Hi Juergen

I've enabled debugging but didn't find any useful info (or not useful to me anyhow!)

I have now wiped the site and reinstalled typesetter. I then extracted the zip file from the previous site export on my local machine and uploaded the contents via FTP. I reset the write access to the data folder and now the site looks like it should.  However, I still get the same "Oops, that didn't work, please try again. (Data Not Saved)" error if I try to log in.  I even tried copying the users.php from the fresh install over the one uploaded from the zip.  That didn't help either!  I have reinstated the one from the zip currently

I also seem to get random "Session expired (timeout)" errors. Any ideas?

Thanks for your continued support!



2 years ago
Post: 11181
Topic: Migration problems

OK so I've reuploaded the site

Same issue with the theme (or lack of) and login

The error on login is "Oops, that didn't work, please try again. (Data Not Saved)"

It also comes up with:

Browser Warning

The browser you are using is not fully supported. Please upgrade to one of these more modern browsers.


Javascript is required to access site administration.

It appears that you are using an incompatible browser. Make sure you're using a modern browser like Mozilla FireFox or Google Chrome and have javascript enabled.

2 years ago
Post: 11180
Topic: Migration problems

Hi. I was just going on to try to log in and check the exact error message and it appears my new hosts have inexplicably deleted the whole site.  Yes I did try copying the whole site across and will try that again.

I'm thinking back to the old host and just redirect the domain name!

2 years ago


elFinder 2.1.50 in Upcoming Release

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News


Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In