Posts by: artem

Posts: 2
Post: 11248
Topic: Upgrading from 1.71 to 5+

juergen,

Thanks for the recommendation :). I have solved it and I was able to update from 1.71 to 5.1 no problem. The main reason to upgrade was that the new server set up (php 7.2) didn't let anyone log into the admin panel.

Here is how I did it:

  • Backed up the site
  • Updated first to 1.7.2 by replacing /include and tried to log on (no luck)
  • Updated to 2.0 by replacing /include and copying over /addons and /themes, then tried to log on (no luck again)
  • Updated the same way to 3.0 and then 5.1, admin panel started working.

The old theme is a little broken, but I think I can fix it. Everything else works fine.

2 years ago
Post: 11246
Topic: Upgrading from 1.71 to 5+

This is a little awkward: 

There is an outdated website that I need to revive. It is built on Typesetter 1.71. I don't want to rebuild it on a different CMS or do a fresh install before I am sure there is no other way.

Surely, the direct upgrade to 5+ doesn't work. It requires an upgrade to 2.0 first.

Is there a workaround? My ideas are: 

  1. Change the version in the original installation to disable checks. But, I don't know where they are set and I'm quite sure it might not work properly.
  2. Get a copy of 2.0 release first. Is there a chance to get it?

What would you suggest?

2 years ago

News

elFinder 2.1.50 in Upcoming Release
12/28/2019

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1
8/12/2017

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

HH-Support

Company located in T├│rshavn, Faroe Islands. * Webpage Design * Consultant & Provider of a wide range of programs for visually impaired and dyslextics.

Find out more about our Provider Spotlight

Log In

  Register