Posts by: Charles S

Posts: 448
Post: 370
Topic: Get rid of index.php in URLs

sucks there isn't a way to be able to make something like this defualt. .  .


As for my test on my localhost install.

Yes, I followed your example exactly. That example didn't work--would return a error in line 5 of index.php.

I got it to work before using a different mod rewrite; however, I deleted the files for other testing purposes and of course forgot exactly what I did.

I'm sure the mod rewrite I have on my server will work just fine. The reason I went back and tried your rewrite rules again was, when I did the rewrite and it was working the images broke and when I tried to re-upload them the file manager went wonky--it would just return to the file manager page when I would go to browse for the file and I wanted to be able to re-check that to see if it was a bug or not. 

I'll have to upload to my server and play a little--don't really have the time right now. No worries, just wanted to let you know in case the mod rewrite has a localhost install issue. 

I don't know if this is possible, but can you make a mod_rewrite for the home page to be the domain name (*.com/Home = *.com)?



Found the problem. There seems to be a problem in the code of index.php file for "define('gp_indexphp',false);"

I installed gpEasy into glacier subdirectory and just copied your htaccess & index.php examples and it worked fine. Copied the index.php data over to my other subdirectory index.php file and made the appropriate changes and it works fine now. Must be a ' or something in the index.php file. 

I do have another question, sorry.

I tried to add a "/" at the end of the url, but it breaks gpEasy. I used similar rewrite that works with getsimple CMS. Can you give a rewrite for this or is it not possible? And how do I get the "home" page to = domain name ( = it only via a rewrite/redirect?

Also, off topic, do you plan on adding a feature for meta data (description) for each page in the future?

Edited: 13 years ago
Post: 363
Topic: Get rid of index.php in URLs

I've tried the mod rewrite as you suggest--I'm using a localhost install in a subdirectory--and it does not work. I did not load it to my server to try it. I made sure that the subdirectories were written as you specify to my correct subdirectories, but no go. Possibly upload the exact docs you suggest or download?

As others suggest, removing index.php and setting the home page to the domain would be nice as there is no real need for it in the URL.

As it currently stands you never have the domain name as the home page (index page). An example is:  = Not "pretty" URL ;)

It would be best, if possible, if this was by default for users that aren't familiar with mod rewrites as gpEasy is generally very easy to use and I think many users new to the web would really like it. 

Hope that doesn't sound like a "complaint" . . . just a suggestion to make it ultra simple for noob users.


13 years ago
Post: 359
Topic: Multiple Site error

Tried the new plugin. Same results


  • Starting Installation: D:/PortableApps/xampplite/htdocs/99
  • Source Host: localhost
  • Using File Functions
  • Create index.php file... D:/PortableApps/xampplite/htdocs/99/index.php
  • Create Symlink...  Name: D:/PortableApps/xampplite/htdocs/99/include  Target: D:/PortableApps/xampplite/htdocs/trueacu/gpEasy/include Link failed (1)
  • Installation Aborted
Tried a couple different locations but it doesn't like any of it. No worries, not really needed at the moment as long as it works when uploaded. Just wanted to let you know. 
13 years ago
Post: 358
Topic: multiple sites not working

thanks. . .

13 years ago
Post: 333
Topic: multiple sites not working

really, I didn't add this many posts. Seems to come from updating my profile.

Edited: 13 years ago
Post: 332
Topic: multiple sites not working


Edited: 13 years ago
Post: 331
Topic: multiple sites not working


Edited: 13 years ago
Post: 330
Topic: multiple sites not working


I'm new to gpEasy. Just now checking it out as a localhost install. I'm trying to test the multiple sites plugin however it's not working.

This is what I get:

  • Starting Installation: D:/PortableApps/xampplite/htdocs/trueacu/test
  • Source Host: localhost
  • Using File Functions
  • Create index.php file... D:/PortableApps/xampplite/htdocs/trueacu/test/index.php
  • Create Symlink... Name: D:/PortableApps/xampplite/htdocs/trueacu/test/include Target: D:/PortableApps/xampplite/htdocs/trueacu/gpEasy/include Link failed (1)
  • Installation Aborted

I don't know if multiple sites has been attempted on a localhost install before or not.

I've tried several times with same results. Checked permissions and everything looks ok. I'm on a Win7 computer and gpEasy is installed under xampplite.

The base isntall is working fine.

Maybe the path needs to be different or something. I don't know. Looked but couldn't find a lot of info about using the multiple site plugin so here I am :)

FYI. . . so far I like gpEasy. Very simple and easy to use once accustomed to the interface, and being able to manage multiple sites would be the icing on the cake ;)



13 years ago


elFinder 2.1.50 in Upcoming Release

A new release for Typesetter is in the works with a lot of improvements including the ... Read More

Typesetter 5.1

Typesetter 5.1 is now available for download. 5.1 includes bug fixes, UI/UX improvements, ... Read More

More News

Log In